Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a HP Pavilion DV6 3131TX (i5 1st gen, 8GB RAM, AMD HD 5650/Intel graphics, 500GB HDD) and for the most part Ubuntu runs fine so long as I use the Intel graphics. It does however run hot because the AMD graphics are not disabled when using the Intel graphics. I am not really using my Ubuntu partition for gaming, so I don't need the AMD graphics while in Ubuntu.

I found this guide and while I did not have much luck with the commands it suggests to add to Grub, the line that disables the AMD graphics works and my laptop no longer runs hot after using it. The problem is it only works when manually running the command in the terminal. Once I add the command to my /etc/rc.local file, my Ubuntu install will not boot - I just get stuck at the Ubuntu splash screen while the fan goes crazy. If I boot without the charger plugged in, the fan does not go crazy but it takes much much longer to boot.

The guide I followed (originally followed Grub-related instructions but removed while troubleshooting the issue of the laptop not booting):

http://usernamepending.wordpress.com/2011/11/02/getting-back-some-battery-life-in-ubuntu-11-10-by-disabling-discrete-graphics/

The command is:

sudo echo OFF > /sys/kernel/debug/vgaswitcheroo/switch

Is there a better place to add this line - perhaps somewhere that will run the command later but without prompting me for my password (strongly preferred, already have to type once to login)?

My laptop does not have an option to disable the AMD graphics in the BIOS.

share|improve this question
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.