Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have this odd, quite minor, but annoying issue that I am quite perplexed about. Whenever I try to upload a file via my browser(let's say attach a file to an email in GMail), I click 'Browse' button and it opens standard file selection dialog, that doesn't show network drives. Further more if I try to drag a file from a network drive into GMail, it doesn't work either, it just doesn't let me do that.

This issue has been around for quite sometime now, and I am just curious if this is something on my side or if it's a bug or a misconfiguration of some sort.

FWIW, I am currently running 10.10, network drive is a samba share on NAS. This happens in FF and Chrome and this is only happens with Samba mounts. As a matter of fact, NFS volumes that are located on the same network operate perfectly fine.

share|improve this question

6 Answers 6

up vote 1 down vote accepted
+50

To mount samba shares in our home directory we may use SMBNetFS install ccsm. With this tool we are able to access samba shares by nearly all applications simply through a mount point in our home directory.

How to use SMBnetFS

  • cp /etc/smbnetfs.conf ~/.smb/smbnetfs.conf copy example configuration file
  • cp /etc/samba/smb.conf ~/.smb/smb.conf copy samba configuration
  • mkdir ~/sambashare or any other name for the mount point
  • smbnetfs ~/sambashare to mount the shares.
  • users need to be member of the fuse group

See man smbnetfs for options and go through the FAQ file in /usr/share/doc/smbnetfs for further documentation.

share|improve this answer

You don't say if this problem is also happening with local drive folders (hard disk drivers physically connected inside of your computer). Which would be the first that I would ask you to perform in order to add further information that can help you to find a solution.

If you can't do what you wish with a local file (let's say in your desktop), then this is not a network based issue but probably your browser is finding a limitation, which may include but not limits only to the FireWall. Try then disabling firewall and achieve this task both in your local and remote files.

You can disable firewall by using a GUI like Firestarter. Which may be in the default repositories inside of Synaptic.

Let's wait for your answer in order to change/delete this.

share|improve this answer
    
Sorry forgot to mention this. No this is only happening with Samba mounts. As a matter of fact, NFS volumes that are located on the same network operate perfectly fine. –  Alex Apr 17 '11 at 4:58

I could workaround an issue like this by selecting the file at the folder ~/.gvfs instead of the folder showed as a network folder.

ps. ~/.gvfs is where Nautilus mount the samba share.

share|improve this answer
    
Actually I did try that too, and it won't let me past ~/.gvfs/MOUNTNAME , i.e. it shows mounts that are available but doesn't allow to open them them. –  Alex Apr 17 '11 at 5:01
    
In that case looks like it's a permission issue. –  Andrea Lazzarotto Apr 17 '11 at 12:15

You could check if it's a file permission issue.

First, open a terminal and run the following commands:

cd ~/.gvfs
ls -la

If you see that the samba mountpoints don't have global execute -permissions (e.g. like this: drwx--x--- ), then you can try adding permissions to the share with the command:

chmod 777 sharefolder

this command will give all user accounts on your computer read+write+transfer permissions to the mount folder in question. If your browser has been using a different user account than yours, it may solve the issue.

share|improve this answer
    
Hm, yes you're right, right now permissions on the mount are set to 700. If I try to setup them to 777 or anything else for that matter I get 'operation not supported' :( –  Alex Apr 17 '11 at 20:05
    
Try 755, may work better than 700 –  Geppettvs D'Constanzo Apr 18 '11 at 15:23

Instead you can just drag and drop the file and it attaches fine. This works for attaching files in Thunderbird from a network drive.

share|improve this answer

Well I hate to reopen an old thread buuut I found this and after scouring the interweb some more, I thought I might let any future viewers know:

https://wiki.ubuntu.com/MountWindowsSharesPermanently

That worked 100% for me, I can now access windows shares system wide, including from the file upload dialog in my browser. Hope this helps someone in the future.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.