Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Hello what do I have to write in the file "/etc/fstab" to get my windows-partition (/dev/sda3) automatically mounted on startup ?

I get this error-message (clicking on the bookmark for the partition in nautilus):

    Error mounting: mount exited with exit code 1: helper failed with:
  Unprivileged user can not mount NTFS block devices using the external FUSE
library. Either mount the volume as root, or rebuild NTFS-3G with integrated
FUSE support and make it setuid root. Please see more information at
http://ntfs-3g.org/support.html#unprivileged

My fstab looks like this:

> # /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
/dev/sdb6       /               ext4    errors=remount-ro 0       1
/dev/sda3   /media/Jonas    ntfs    rw,auto,users,nls=utf8,umask=007,gid=46  0  0

# swap was on /dev/sdb7 during installation
UUID=9dcdfad2-4e66-416e-bf68-142afe23fa0b none            swap    sw              0       0

I created the folder /media/Jonas and the partition is /dev/sda3. What did I wrong ?

Solution: After rebooting, it worked well. Strange.

share|improve this question
    
could you post the output of ls -la /media/Jonas ? you can try sudo chown root:plugdev /media/Jonas –  turbo Apr 12 '11 at 18:49

3 Answers 3

up vote 5 down vote accepted

Assume you are sure about: - Your created directory is /media/Jonas (with uppercase J) - Your ntfs partition is /dev/sda3 (you can find this out by issuing sudo blkid)

My fstab uses a simpler form:

/dev/sda3   /media/windows  ntfs    defaults    0   0

You may change your "rw,auto, ...." to "defaults"

share|improve this answer
    
thanks, it looks a little bit easier . –  Pablo Apr 13 '11 at 7:31

While I generally recommend disabling fast startup on Windows 8, sometimes even that won't solve, in that case I used:

 sudo ntfs-3g -o remove_hiberfile /dev/sda2 /path/to/mount

In my case /path/to/mount was my personal folder on /media, /dev/sda2 was my windows partition

share|improve this answer
    
I really wish I didn't have to do this all the time, but it seems Windows creates the hiberfile no matter how I setup it. –  user3083324 Oct 13 at 22:55

There's a good answer to the NTFS-3g problem here.

http://ubuntuforums.org/showthread.php?t=1661757

share|improve this answer
1  
Could you please elaborate on what kind solution the link contains so that people will benefit even if the link dies. –  N.N. Nov 14 '11 at 6:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.