Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to initialize a Android build environment on Ubuntu 10.04.4. I have followed the instructions provided by Google and have run into a issue at the following step under "Installing Required Packages (Ubuntu 10.04 -- 11.10)." I run the following commands provided by Google:

sudo apt-get install git-core gnupg flex bison gperf build-essential \
> zip curl zlib1g-dev libc6-dev lib32ncurses5-dev ia32-libs \
> x11proto-core-dev libx11-dev lib32readline5-dev lib32z-dev \
> libgl1-mesa-dev g++-multilib mingw32 tofrodos python-markdown \
> libxml2-utils xsltproc

When I attempt to run this section of the setup process I receive the following error:

$ sudo apt-get install git-core gnupg flex bison gperf build-essential \
>   zip curl zlib1g-dev libc6-dev lib32ncurses5-dev ia32-libs \
>   x11proto-core-dev libx11-dev lib32readline5-dev lib32z-dev \
>   libgl1-mesa-dev g++-multilib mingw32 tofrodos python-markdown \
>   libxml2-utils xsltproc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
git-core is already the newest version.
gnupg is already the newest version.
flex is already the newest version.
bison is already the newest version.
gperf is already the newest version.
build-essential is already the newest version.
zip is already the newest version.
curl is already the newest version.
zlib1g-dev is already the newest version.
libc6-dev is already the newest version.
lib32ncurses5-dev is already the newest version.
ia32-libs is already the newest version.
x11proto-core-dev is already the newest version.
libx11-dev is already the newest version.
lib32readline5-dev is already the newest version.
Note, selecting lib32z1-dev instead of lib32z-dev
lib32z1-dev is already the newest version.
libxml2-utils is already the newest version.
xsltproc is already the newest version.
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libgl1-mesa-dev: Depends: libgl1-mesa-glx (= 7.7.1-1ubuntu2) but 7.7.1-1ubuntu3 is to              be installed
E: Broken packages

I'm new to this, so I would appreciate any help on what is causing the problem and how to fix this. Thank you.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.