Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm try to build to build Clang and LLVM and after download it I want to configure it so when I do that command :

../llvm/configure --prefix=/usr/clang_3_3 --enable-optimized --enable-targets=host

it's show me error configure permission Denied even when I'm root and I try

chmod +x

it didn't work any help

Note : I download Clang and LLVM from svn and I put it to anthor dir(not the root) in /media one of these dirs

share|improve this question
    
Are these files on an external hard disk? Try putting them in your ~ home directory instead. –  minerz029 Sep 18 '13 at 23:04
    
I have no enough space –  userCS Sep 18 '13 at 23:11
    
any other solution ? –  userCS Sep 18 '13 at 23:18

1 Answer 1

up vote 0 down vote accepted

You need to put it on a Linux file system. Microsoft Windows file-systems do not support setting the executable bit.

Try these workarounds:

  • You could run it like (with bash in front, assuming it opens with bash)

    bash ../llvm/configure --prefix=/usr/clang_3_3 --enable-optimized --enable-targets=host
    
  • You could create a small ext4 partition on an external hard drive and put the files on there
  • See here: How to 'chmod' on an NTFS ( or FAT32 ) partition?
share|improve this answer
    
Yaa that's work :) Thanks –  userCS Sep 19 '13 at 0:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.