Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed mercurial from the PPA, then I wanted to install hgsubversion. That fails due to unmet dependencies. But they are met, as far as I understand. What am I missing here?

jb@x60 ~ $ apt-cache policy mercurial
mercurial:
  Installed: 2.7-0ppa1
  Candidate: 2.7-0ppa1
  Version table:
 *** 2.7-0ppa1 0
        500 http://ppa.launchpad.net/mercurial-ppa/releases/ubuntu/ raring/main i386 Packages
        100 /var/lib/dpkg/status
     2.2.2-2 0
        500 http://ftp.tu-chemnitz.de/pub/linux/ubuntu/ raring/universe i386 Packages
jb@x60 ~ $ sudo apt-get install hgsubversion
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 hgsubversion : Depends: mercurial (>= 1.9.1-1~) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Other info:

jb@x60 ~ $ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description:    Linux Mint 15 Olivia
Release:    15
Codename:   olivia
share|improve this question

1 Answer 1

up vote 1 down vote accepted

Investigating debian/control in the PPA's mercurial source package, we see that it has:

Breaks: hgsubversion (<< 1.5~)

So if you want hgsubversion you are going to need a newer version (1.5-1 is available in saucy).

As an aside, in this situation you can also see the error by running:

sudo apt-get install -oDebug::pkgProblemResolver=yes hgsubversion

which tells us near the beginning that:

Investigating (0) mercurial [ amd64 ] < 2.7-0ppa1 > ( universe/devel )
Broken mercurial:amd64 Breaks on hgsubversion [ amd64 ] < none -> 1.4-1 > ( universe/vcs ) (< 1.5~)
  Considering hgsubversion:amd64 9998 as a solution to mercurial:amd64 5
  Removing mercurial:amd64 rather than change hgsubversion:amd64
share|improve this answer
    
Or not use the ppa at all. –  Braiam Sep 23 '13 at 13:03
    
After I tried to trick dpkg with a dummy dependant (which didn't work) and reverted that, I was not able to reproduce the original error message anymore. Instead I got the one you post here. ... strange? Thanks for the hint with saucy. Installed saucy's version of hgsubversion and all is fine. @Braiam: Not using the ppa at all is not an option. Why did I use it in the first place if there was not need for that? ;) –  JoBo Sep 30 '13 at 16:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.