Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libglapi-mesa-lts-raring : Conflicts: libglapi-mesa
 libxcb1 : Depends: libxau6 but it is not going to be installed
           Depends: libxdmcp6 but it is not going to be installed
 openssh-server : Depends: openssh-client (= 1:5.9p1-5ubuntu1)
                  Recommends: xauth but it is not going to be installed
                  Recommends: ssh-import-id but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

In ubuntu software center, following message occurs.

The following packages have unmet dependencies:

libglapi-mesa-lts-raring: libxcb1: Depends: libc6 (>= 2.14) but 2.15-0ubuntu10.4 is to be installed
share|improve this question
Seems that you have a mess of dependencies, can you get the output of sudo apt-get check and apt-cache policy libxcb1 openssh-server openssh-client? Edit your question and add the requested information. –  Braiam Sep 18 '13 at 14:00
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.