Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Recently (I don't don't know when, might have been after and update) the sound indicator disappeared from my panel, in addition I haven't been getting any sound either. I tried installing the indicator-sound package, but all I got was this error message:

  The following packages have unmet dependencies:
  indicator-sound: Depends: libido-0.1-0 (>= 0.1.1) but it is not going to be installed
  E: Broken packages

Seems to be a bug, but how do I get around it? Could I install and older version of libido? If so, how do I do that?

Everything had worked fine until a couple days ago, so I'm sure that the package is the problem.

EDIT:The command $ dpkg --get-selections | grep libido returns the following output:

libido-0.1-0                    deinstall

EDIT2:Ok, that's embarassing. Yesterday I uninstalled and reinstalled the libido package half a dozen times, and the indicator-sound package kept reporting the same error. Today, however, I just installed the libido package and now the indicator-sound package installed with no errors. Maybe the system needed a reboot or something.

(Should I answer my own question or just wait for a moderator to close it?)

share|improve this question
1  
What (if any) version of libido do you have installed? (From commandline: dpkg --get-selections | grep libido) –  Marco Ceppi Sep 2 '10 at 12:55
    
@Marco Ceppi: Answered your question. –  Bruce Connor Sep 2 '10 at 13:26
1  
Go ahead and answer your question with the steps it took you to resolve this - it's still a valid question and may come in handy for another user. –  Marco Ceppi Sep 2 '10 at 13:38
add comment

1 Answer 1

up vote 4 down vote accepted

Ok, I manage to solve it. I just installed the libido package and now the indicator-sound package installed with no errors. Maybe the system needed a reboot with the package uninstalled or something. If someone's having this problem, you can try:

sudo apt-get remove libido-0.1-0 
sudo apt-get remove indicator-sound

Restart your computer (this is the part that seems to have solved it). And then reinstall both packages.

sudo apt-get install libido-0.1-0 
sudo apt-get install indicator-sound

It's worth mentioning that, even after the reboot, the terminal kept reporting error messages when I tried to install indicator-sound. But after I reinstalled libido manually, the indicator-sound installed without issues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.