Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running 12.10. Attempting to login via gdm lands me back at the login page. The behaviour is the same for when I switched to lightdm. Logging in with guest is fine, and logging in with a test account I created is fine.

If I access tty1, login with my account and then startx, I get to my desktop fine.

Any ideas? I have tried chowning Xauthority and then removing it but to no success. The problem appears to be a setting in my account, although I have no idea what as when I last used my computer before the problem occurred I didn't do anything abnormal (i.e. system updates or changing any user settings).

UPDATE: SOLVED

Solved thanks to help from Braiam. My ~/.xsession-errors.old file had the following:

/usr/sbin/lightdm-session: 34: /home/*username*/.profile: source: not found
/usr/sbin/lightdm-session: 42: /home/*username*/.profile: Syntax error: "(" unexpected

I had recently added some lines to my .profile to provide useful git information in my prompt. It worked fine when logging in via tty1 and then running startx, however it seems it was stopping me from logging in via gdm / lightdm

share|improve this question
    
Thanks for the tip. xsession errors pointed me to ~/.profile. Turns out I had recently updated my .profile and had completely forgotten disregarded it (as the additions I made were functional when operating on tty1. Commenting out the offending lines solved the problem. Thanks again –  Lobe Sep 18 '13 at 1:14
    
Done. Thanks again for your help –  Lobe Sep 18 '13 at 1:37
add comment

1 Answer

up vote 1 down vote accepted

The ~/.xsessions-erros.old reveals errors found on your ~/.profile file. You should check the syntax and fix the offending line.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.