Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm in Ubuntu 13.04 64 bits and I've noticed that my windows change of workspace themselves, that's very annoying and I want to fix it.

I couldn't say when it changes exactly. But I've noticed that they changes when I press Alt+Tab to change the window, suddenly, my window has changed of workspace!! It specially happen when the window to I switch with alt+tab if it was moved in the screen by me, above all if it was moved near to the edges of the screen.

It has happened from the beginning of my installation of Ubuntu and I've found anyway of fix it in compizConfig neither ubuntu tweaky tool.

share|improve this question
    
I have experienced the same problem on my system. I suspect that I will find it as a reported bug on launchpad.org. I will try to find some answers for this. –  Nullet Sep 17 '13 at 22:57
add comment

1 Answer 1

I'm not sure how you're getting the windows into different workspaces in the first place, but if you want to put them back, Ctrl-Alt-Shift-Arrow will allow you to move them between workspaces.

For a more permanent solution, if you don't want to use workspaces at all, you can use the compizconfig-settings-manager to disable them. Open the settings manager, select the General Options then Desktop Size tab. Set the horizontal and vertical size to 1 and you will no longer have multiple workspaces.

share|improve this answer
1  
Sorry, but is not a solution or an answer. –  Nullet Sep 17 '13 at 22:55
    
As Nullet said, no one is a solution for me. I want to use more than a one workspace but the windows doesn't move themselves. Thanks anyway. –  Akronix Sep 18 '13 at 22:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.