Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a bluetooth mouse ("A4TECH BT-630") and a small laptop with a tiny bluetooth module connected via USB. I'd been using Lubuntu Oneiric for 2 years. My mouse worked flawlessly (I used blueman to set up connection: no pairing, only connect to pointing service). Recently I decided to check out some modern ubuntu-based OS. So I installed Ubuntu Precise (of course, I use blueman as a graphical front-end with same configuration). I turn on my machine, then I log in, after that I switch on my mouse (there is an on/off switch on the bottom of the mouse). Mouse connects, the red light on the bottom turns on, in dmesg I see the following:

[ 2041.034103] input: BlueTooth Mouse as /devices/pci0000:00/0000:00:1d.1/usb3/3-1/3-1:1.0/bluetooth/hci0/hci0:43/input11
[ 2041.036008] generic-bluetooth 0005:09DA:80F0.0003: input,hidraw0: BLUETOOTH HID v0.1e Keyboard [BlueTooth Mouse] on 00:83:15:39:AC:D4

but the pointer doesn't move. Then I switch the mouse off, switch it on again (red light appears, the same strings in dmesg are printed) and everything works fine. Every time I start my machine I face this problem. It also appears periodically when I try to "wake" my mouse. Yesterday I installed Linux Mint Maya Mate (12.04 based distribution). The problem remained. Okay, the kernel is 3.2.x. In Oneiric it was 3.0.x . So I downloaded 3.0.9 compat-wireless, 3.0.x headers and compiled "btinstall" target. This made no changes. When I turn on my machine, I can't make pointer move for a first time. And it's quite annoying. So... maybe someone can help me? P.S. I also tried to configure the mouse using this instruction: Arch: bluetooth mouse configuration No changes.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.