Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My mouse was working fine up until this morning. Since then my mouse has stopped working. However the red led bottom is still on and it works in Windows on same machine. The keyboard is unaffected. There is not error messages fired at boot time. What can be the possible reason and how can this be solved.

-- EDIT --

Yesterday I went Out of Space. so I cleared /tmp, /var/tmp. after some googling I saw few guys in some forum clearing /var/cache. So I cleared /var/cache too. and everything went nice even after that. Now on morning Its actually gdm is refusing to take any input (not even keyboard Inputs) I thought to reinstall gdm. But apt is complaining about missing /var/cache/apt

share|improve this question
How is this mouse connected to your PC? USB, Bluetooth, PS/2, ...? – JanC Sep 2 '10 at 8:40
Also, did you change something, install something new, install updates before the reboot after which it didn't work anymore, etc.? – JanC Sep 2 '10 at 8:43
No the Problem lies somewhere else. See Edit Please. I cleared /var/cache and probabbly for that reason gdm refusing to take any input. apt is not working even. What can be done other than copying some else's /var/cache. – user1868 Sep 2 '10 at 10:33
I think you will need to rebuild /var/cache. I have tried to fix just apt after removing /var/cache apt and have so far been unsuccessful and had to restore the apt directory manually. You could try t copy this across from the installation CD. – Richard Holloway Sep 2 '10 at 12:28
The question about the missing /var/cache probably should be asked as a separate question. – moberley Sep 3 '10 at 4:59
up vote 1 down vote accepted

I am not sure however it might get solved by rebuilding /var/cache. But You really donno What file to put. Just Copying from others might not solve the problem untill you know the trigger point (e.g. exactly which folder/file is missing there).

I've reinstalled hal. and It Started working again. :-)

sudo apt-get --purge -remove hal
sudo apt-get install hal

However Now I think. just making the following directories manually should work.


and expecially /var/cache/hald

However I am not still sure whether it will work or not without a /var/cache/hald/fdi-cache

and I don't think its possible to make this one manually. unless you copy from others. However I do still have hope that you don't need to create /var/cache/hald/fdi-cache manually

share|improve this answer

If you have too many USB devices plugged in, they may be underpowered. Also there seems to be some (random) bug in modern kernels where a powered usb device confused the kernel and it stops loading up other usb devices.

  • Unplug every USB device
  • Boot up to the GDM
  • Reconnect your keyboard and mouse
  • If needed, try them on different USB ports.
  • Give it a few seconds

If this solves your problem, go get yourself a powered USB hub. If you already have a powered USB hub, try removing the power to it, during boot, and connecting the power as soon as the GDM is in front of you.

share|improve this answer

Update the BIOS on the computer. I bet you that's where the problem originates from.

share|improve this answer
No Man. You lost the bet. – user1868 Sep 4 '10 at 17:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.