Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Last week, I experienced a problem with wired connection on my Ubuntu 12.04 installation. I'm in a college dorm and I have to connect to the dorm network using 802.1x security. It worked great on both my Windows 7 and Ubuntu 12.04 installations (dual boot) until the connection started failing on Ubuntu. It would start to try to connect (Network Manager icon going ''up and down'') and after 30-40 seconds a window would jump out, asking me to enter my username and password for 802.1x. When I did, it would just keep trying to connect and after 30-40 seconds the same window would jump out.

My Ubuntu 12.04 install was fairly fresh and I planned on upgrading to 13.04 anyway, so I removed 12.04 installation and installed 13.04. Everything went smoothly, but networking issue remains.

Here is my ifconfig and lshw:

ifconfig

eth0      Link encap:Ethernet  HWaddr ac:22:0b:0f:eb:9f  
          inet6 addr: fe80::ae22:bff:fe0f:eb9f/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3 errors:0 dropped:0 overruns:0 frame:0
          TX packets:56 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:180 (180.0 B)  TX bytes:11073 (11.0 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:105 errors:0 dropped:0 overruns:0 frame:0
          TX packets:105 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:9362 (9.3 KB)  TX bytes:9362 (9.3 KB)

lshw

*-network
       description: Ethernet interface
       product: RTL8111/8168 PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0.2
       bus info: pci@0000:04:00.2
       logical name: eth0
       version: 0a
       serial: ac:22:0b:0f:eb:9f
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl8411-1_0.0.3 06/18/12 latency=0 link=yes multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:d000(size=256) memory:f2104000-f2104fff memory:f2100000-f2103fff

EDIT: After some additional googling, I discovered that Realtek 8168 is known for having problems with Linux: http://www.twm-kd.com/linux/realtek-rtl81688111e-and-ubuntu-linux/ http://unixblogger.wordpress.com/2011/10/18/the-pain-of-an-realtek-rtl8111rtl8168-ethernet-card/

I downloaded latest driver from Realtek's website (version 8.036.00), installed it according to readme file found with it, everything ran smoothly... but it's still not working.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Press Ctrl+Alt+T and then enter this in the command prompt :

echo on | sudo tee /sys/class/net/eth0/device/power/control

share|improve this answer
    
did this work in addition to updating the driver? I did this and still had some dropped connections –  bjackfly Oct 22 '13 at 18:06
    
It did. However, if it doesnt work, you still can restart your network services using sudo /etc/init.d/networking restart –  Kelvinelove Oct 22 '13 at 20:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.