Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to do a long overdue upgrade of a Ubuntu server from 11.10 (through do-release-upgrade). The 11.10 is updated.

Version, architecture and kernel:

$ lsb_release -a
Distributor ID: Ubuntu
Description:    Ubuntu 11.10
Release:        11.10
Codename:       oneiric
$ uname -r
2.6.38-8-virtual
$ dpkg --print-architecture
amd64

I'm getting the following output when running do-release-upgrade.

Checking package manager Reading package lists... Done

A fatal error occurred 

Please report this as a bug and include the files  /var/log/dist-upgrade/main.log and /var/log/dist-upgrade/apt.log in  your report. The upgrade has aborted.  Your original sources.list was saved in  /etc/apt/sources.list.distUpgrade. 

Traceback (most recent call last): 
File "/tmp/update-manager-SNK0hu/precise", line 7, in <module>  sys.exit(main()) 
File "/tmp/update-manager-SNK0hu/DistUpgradeMain.py", line 226, in  main  if app.run(): 
File "/tmp/update-manager-SNK0hu/DistUpgradeController.py", line  1721, in run return self.fullUpgrade() 
File "/tmp/update-manager-SNK0hu/DistUpgradeController.py", line  1639, in lUpgrade  self.openCache() 
File "/tmp/update-manager-SNK0hu/DistUpgradeController.py", line 192,  in openCache  lock) 
File "/tmp/update-manager-SNK0hu/DistUpgradeCache.py", line 92, in __init__  apt.Cache.__init__(self, progress) 
File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 93, in __init__  self.open(progress) 
File "/usr/lib/python2.7/dist-packages/apt/cache.py", line 136, in  open self._cache = apt_pkg.Cache(progress) 

SystemError: E:The value 'oneiric' is invalid for  APT::Default-Release as such a release is not available in the  sources 

This is my /etc/apt/sources.list, maybe something wrong with that one?

# 
# deb cdrom:[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/ lucid main restricted

# deb cdrom:[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/ lucid main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://old-releases.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://old-releases.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://old-releases.ubuntu.com/ubuntu/ oneiric universe
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric universe
deb http://old-releases.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://old-releases.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric multiverse
deb http://old-releases.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://old-releases.ubuntu.com/ubuntu/ oneiric-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse
# deb-src http://old-releases.ubuntu.com/ubuntu/ lucid-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu lucid partner
# deb-src http://archive.canonical.com/ubuntu lucid partner

deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

deb http://archive.canonical.com/ oneiric partner
deb http://pkg.jenkins-ci.org/debian binary/
deb http://old-releases.ubuntu.com/ubuntu natty main restricted universe multiverse
deb-src http://old-releases.ubuntu.com/ubuntu natty main restricted universe multiverse

01ubuntu in /etc/apt/apt.conf.d/ has this text:

APT::Default-Release "oneiric"; 

10periodic in same location has:

 APT::Periodic::Update-Package-Lists "1";
 APT::Periodic::Download-Upgradeable-Packages "0"; 
 APT::Periodic::AutocleanInterval "0";

This is the apt.log file:

Log time: 2011-10-16 20:32:42.241760
Log time: 2011-10-16 20:32:50.327655
Log time: 2011-10-16 20:33:06.970803
  Installing libssl1.0.0 as Depends of openssh-server
  Installing gcc-4.6-base as Depends of libstdc++6
  Installing libtinfo5 as Depends of libncurses5
  Installing libdb5.1 as Depends of iproute
  Installing libgcj12 as Depends of libgcj-bc
    Installing gcj-4.6-base as Depends of libgcj12
    Installing libgmp10 as Depends of libgcj12
    Installing gcj-4.6-jre-lib as Recommends of libgcj12
  Installing libapt-pkg4.11 as Depends of aptitude
  Installing libboost-iostreams1.46.1 as Depends of aptitude
  Installing accountsservice as Depends of language-selector-common
    Installing libpolkit-gobject-1-0 as Depends of accountsservice
    Installing libaccountsservice0 as Depends of accountsservice
  Installing libapt-inst1.3 as Depends of python-apt
  Installing libffi6 as Depends of libgirepository-1.0-1
  new important dependency: libswitch-perl
  Installing libswitch-perl as Recommends of perl-modules
  new important dependency: libpod-plainer-perl
  Installing libpod-plainer-perl as Recommends of perl-modules
  new important dependency: libclass-isa-perl
  Installing libclass-isa-perl as Recommends of perl-modules
  Installing grub2-common as Depends of grub-pc
  Installing grub-pc-bin as Depends of grub-pc
  Installing linux-image-3.0.0-12-virtual as Depends of linux-image-virtual
  Setting NOT as auto-installed (direct Depends of pkg in APT::Never-MarkAuto-Sections)
  Installing libjsr305-java as Depends of libgoogle-collections-java
  Installing libpciaccess0 as Depends of libdrm-intel1
  Installing python-gobject-2 as Depends of python-gobject
  Installing libusb-1.0-0 as Depends of usbutils
  Installing librhino-java as Depends of rhino
  Installing libmount1 as PreDepends of mount
  Installing libasyncns0 as Depends of libpulse0
  Installing libjson0 as Depends of libpulse0
  Installing xorg-sgml-doctools as Depends of libx11-dev
  Installing librtmp0 as Depends of libcurl3-gnutls
  Installing libencode-locale-perl as Depends of libwww-perl
  Installing libfile-listing-perl as Depends of libwww-perl
    Installing libhttp-date-perl as Depends of libfile-listing-perl
  Installing libhttp-cookies-perl as Depends of libwww-perl
    Installing libhttp-message-perl as Depends of libhttp-cookies-perl
      Installing liblwp-mediatypes-perl as Depends of libhttp-message-perl
  Installing libhttp-negotiate-perl as Depends of libwww-perl
  Installing liblwp-protocol-https-perl as Depends of libwww-perl
    Installing libnet-http-perl as Depends of liblwp-protocol-https-perl
      Installing libio-socket-ssl-perl as Recommends of libnet-http-perl
        Installing libnet-ssleay-perl as Depends of libio-socket-ssl-perl
  Installing libwww-robotrules-perl as Depends of libwww-perl
  new important dependency: libhtml-form-perl
  Installing libhtml-form-perl as Recommends of libwww-perl
  new important dependency: libhttp-daemon-perl
  Installing libhttp-daemon-perl as Recommends of libwww-perl
Starting
Starting 2
Investigating (0) console-setup [ amd64 ] < 1.57ubuntu20 -> 1.57ubuntu27 > ( utils )
Broken console-setup:amd64 Conflicts on console-terminus [ amd64 ] < 4.30-2 > ( fonts )
  Considering console-terminus:amd64 -1 as a solution to console-setup:amd64 17
  Added console-terminus:amd64 to the remove list
  Fixing console-setup:amd64 via remove of console-terminus:amd64
Done
Log time: 2011-10-16 20:27:59.832015
Starting
Starting 2
Investigating (0) libgtk2.0-0 [ amd64 ] < 2.24.6-0ubuntu5 > ( libs )
Broken libgtk2.0-0:amd64 Depends on libatk1.0-0 [ amd64 ] < 2.2.0-0ubuntu1 > ( libs ) (>= 1.12.4)
  Considering libatk1.0-0:amd64 10001 as a solution to libgtk2.0-0:amd64 5
  Removing libgtk2.0-0:amd64 rather than change libatk1.0-0:amd64
Investigating (0) libgtk2.0-bin [ amd64 ] < 2.24.6-0ubuntu5 > ( misc )
Broken libgtk2.0-bin:amd64 Depends on libgtk2.0-0 [ amd64 ] < 2.24.6-0ubuntu5 > ( libs ) (>= 2.24.6-0ubuntu5)
  Considering libgtk2.0-0:amd64 5 as a solution to libgtk2.0-bin:amd64 3
  Removing libgtk2.0-bin:amd64 rather than change libgtk2.0-0:amd64
Done
Starting
Starting 2
Investigating (0) x-ttcidfont-conf [ amd64 ] < 32+nmu2 > ( x11 )
Broken x-ttcidfont-conf:amd64 Depends on defoma [ amd64 ] < 0.11.12ubuntu1 > ( admin ) (>= 0.5.0)
  Considering defoma:amd64 10001 as a solution to x-ttcidfont-conf:amd64 1
  Removing x-ttcidfont-conf:amd64 rather than change defoma:amd64
Done
Starting
Starting 2
Investigating (0) libgcj11 [ amd64 ] < 4.5.3-9ubuntu1 > ( universe/libs )
Broken libgcj11:amd64 Depends on gcj-4.5-base [ amd64 ] < 4.5.3-9ubuntu1 > ( universe/libs ) (>= 4.5.3-9ubuntu1)
  Considering gcj-4.5-base:amd64 10002 as a solution to libgcj11:amd64 2
  Removing libgcj11:amd64 rather than change gcj-4.5-base:amd64
Investigating (0) gcj-4.5-jre-lib [ amd64 ] < 4.5.3-9ubuntu1 > ( universe/java )
Broken gcj-4.5-jre-lib:amd64 Depends on gcj-4.5-base [ amd64 ] < 4.5.3-9ubuntu1 > ( universe/libs ) (>= 4.5.3-2~)
  Considering gcj-4.5-base:amd64 10002 as a solution to gcj-4.5-jre-lib:amd64 2
  Removing gcj-4.5-jre-lib:amd64 rather than change gcj-4.5-base:amd64
Done
Starting
Starting 2
Investigating (0) libthai0 [ amd64 ] < 0.1.15-2 > ( libs )
Broken libthai0:amd64 Depends on libthai-data [ amd64 ] < 0.1.15-2 > ( libs ) (>= 0.1.10)
  Considering libthai-data:amd64 10001 as a solution to libthai0:amd64 1
  Removing libthai0:amd64 rather than change libthai-data:amd64
Investigating (0) libpango1.0-0 [ amd64 ] < 1.29.3+git20110916-0ubuntu1 > ( libs )
Broken libpango1.0-0:amd64 Depends on libthai0 [ amd64 ] < 0.1.15-2 > ( libs ) (>= 0.1.12)
  Considering libthai0:amd64 1 as a solution to libpango1.0-0:amd64 0
  Removing libpango1.0-0:amd64 rather than change libthai0:amd64
Done
Starting
Starting 2
Investigating (0) libgdk-pixbuf2.0-0 [ amd64 ] < 2.24.0-1ubuntu1 > ( libs )
Broken libgdk-pixbuf2.0-0:amd64 Depends on libtiff4 [ amd64 ] < 3.9.5-1ubuntu1 > ( libs )
  Considering libtiff4:amd64 10001 as a solution to libgdk-pixbuf2.0-0:amd64 0
  Removing libgdk-pixbuf2.0-0:amd64 rather than change libtiff4:amd64
Done
Starting
Starting 2
Investigating (0) groovy [ amd64 ] < 1.7.10-2 > ( universe/devel )
Broken groovy:amd64 Depends on libjansi-java [ amd64 ] < 1.4-3 > ( universe/java )
  Considering libjansi-java:amd64 10001 as a solution to groovy:amd64 0
  Removing groovy:amd64 rather than change libjansi-java:amd64
Done
Starting
Starting 2
Investigating (0) libxcursor1 [ amd64 ] < 1:1.1.12-1 > ( libs )
Broken libxcursor1:amd64 Depends on libxfixes3 [ amd64 ] < 1:5.0-4 > ( libs )
  Considering libxfixes3:amd64 10001 as a solution to libxcursor1:amd64 0
  Removing libxcursor1:amd64 rather than change libxfixes3:amd64
Done

Due to size, the main log file is at http://pastebin.com/z6Muqggn

Any suggestions on what this could be or how to solve it?

share|improve this question

closed as off-topic by Braiam, Mahesh, Warren Hill, Luis Alvarado Jul 27 at 16:57

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Braiam, Mahesh, Warren Hill, Luis Alvarado
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Thanx for your suggestion! I've updated the description above with some more details. I can't seem to find that anything has a similar issue as what the ticket was referring to. –  jornk Sep 17 '13 at 12:15
    
@Rinzwind, you were correct! Got help from a colleague who resorted the issue as described above - sometimes good to have a set of fresh eyes look at an issue :) Could you please post your suggestion as a reply so I can mark it as good answer? –  jornk Sep 18 '13 at 7:08
    
Of course jornk :) –  Rinzwind Sep 18 '13 at 7:13

1 Answer 1

I found this solution on launchpad:

Places to check:

  • /etc/apt/apt.conf.d/10periodic
  • /etc/apt/sources.list

Look for "APT::Default-Release" line.

After an update, my sources.list was mass-changed from "oneiric" to "precise". But I haven't upgraded the system to precise yet. (At least, the system doesn't think so.)

In sources.list, I copied the top two lines that read:

 deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

and edited them to say:

deb http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted

Then, update-manager offered a "Partial upgrade". Not quite working, but appears to be progress. I suppose one could also try changing the APT::Default-Release from "oneiric" to "precise", too.

source: Romulus@launchpad

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.