Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently saddled with a Swedish keyboard at work (TMALSS: I left my nice Japanese one at home), which has some deadkeys, one of which is backtick.

I can type a backtick just fine in any application save RubyMine (and probably any stupid JVM app) either by pressing S-Backtick S-Backtick (i.e. pressing Backtick twice whilst holding down Shift), or by pressing S-Backtick Space.

Any clues what could be going on here? It almost certainly has to be Java, but I don't know anything about adjusting Java input settings or whatever.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I couldn't reproduce the problem in RubyMine on natty.

If you still suffer from the problem, try the following work-around: change the system keyboard layout from Keyboard Preferences > Layouts > Add and pick Country: Sweden and Variants: Sweden Eliminate dead keys. That will give you the backtick by just pressing S-Backtick. If you need to change between the regular and eliminate dead keys layout variants, keep both available in layouts and set a convenient hot key to switch (in the Layouts tab click on Options... and then Key(s) to change layout).

share|improve this answer
    
Wonderful, thank you! I had forgotten all about the option to eliminate dead keys. I blame xorg--when they made configuration so easy, I stopped having to look up keyboard layout names. ;) –  Josh Glover Jul 4 '11 at 7:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.