Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install a softerware with sources after git cloned. The author said the following steps to install it:

git submodule init
git submodule update
mkdir build;cd build
cmake ..
make
sudo make install

but when i go into the step cmake .. ,the error occureed:

    -- checking for module 'purple'
    --   package 'purple' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
      CMakeLists.txt:18 (pkg_check_modules)


    -- checking for module 'glib-2.0'
    --   package 'glib-2.0' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
      CMakeLists.txt:19 (pkg_check_modules)


    -- checking for module 'mozjs185'
    --   package 'mozjs185' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
      CMakeLists.txt:20 (pkg_check_modules)


    libpurple version:Package purple was not found in the pkg-config search path.
    Perhaps you should add the directory containing `purple.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'purple' found
    libpurple version outdate
    -- checking for module 'libcurl'
    --   package 'libcurl' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
      liblwqq/CMakeLists.txt:29 (pkg_check_modules)


    -- checking for module 'sqlite3'
    --   package 'sqlite3' not found
    CMake Error at /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:279 (message):
      A required package was not found
    Call Stack (most recent call first):
      /usr/share/cmake-2.8/Modules/FindPkgConfig.cmake:333 (_pkg_check_modules_internal)
      liblwqq/CMakeLists.txt:30 (pkg_check_modules)


    CMake Error at src/CMakeLists.txt:38 (INSTALL):
      install TARGETS given no LIBRARY DESTINATION for module target "webqq".


    ===============================================
    -- With Libev (Option)     : NO
    -- Native Language Support : true
    -- Install Path            : 
    ===============================================
    -- Configuring incomplete, errors occurred!

And when i installed the glib-2.0 and sqlite3, the error message doesn't change! what's more, the command sudo apt-get install purple doesn't work.

so, what should i do can i finish install this software?

share|improve this question
    
Could you provide the link which such instructions? –  Braiam Sep 17 '13 at 3:30

1 Answer 1

To build program that depends on some libraries you need to install development packages for those libraries. Development packages usually named same as library, but with -dev on the end, e.g. libpurple-dev for libpurple, libsqlite3-dev for libsqlite3 etc.

According to your log you need to install:

apt-get install libpurple-dev libglib2.0-dev libmozjs185-dev \
    libsqlite3-dev libcurl4-gnutls-dev
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.