Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am on Acer 5742G. Here are some specs

Processor : Intel Core i5-460M Mobile Processor (3MB Intel Smart Cache, 2.53GHz)

Chipset : Mobile Intel HM55 Express

Memory : Up to 3GB DDR3 SDRAM

Storage : Up to 500GB SATA hard drive, 5400RPM

Video : NVIDIA GeForce 420M graphics

I have 3.3GB of Swap partition and 2.3GB of ram. But whenever I try to hibernate it says "not enough free swap".

Here is the output of free command

               total       used       free     shared    buffers     cached

 Mem:          2319       1304      

 1014          0        453        544

 -/+ buffers/cache:        306       2012 

 Swap:         3344          0     3344

So you see there is lots of free swap space. Then why is it not hibernating?

share|improve this question

closed as too localized by Bruno Pereira Mar 16 '12 at 16:38

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Did you install your Ubuntu using WUBI? –  omnidan Apr 12 '11 at 8:42
    
I found this thread for you: ubuntuforums.org/showthread.php?t=862557 –  omnidan Apr 12 '11 at 8:45
    
Yes I did install using wubi –  Rick_2047 Apr 12 '11 at 12:56
    
Look at the link I sent you, it's a WUBI related issue. –  omnidan Apr 12 '11 at 14:10
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, –  Ringtail Mar 16 '12 at 16:36

1 Answer 1

Weirdly enough I found that Wubi hibernates just fine, it's just not called "hibernate" in the settings, it's variously called "Sleep" or "Suspend to RAM".

When I go to Settings > System Settings > Advanced > Power Management > Edit Profiles and edit the currently selected power profile (in my case "Powersave"), on the line that says: "When the system is idle for more than"... when I select "suspend to disk" (which matches my definition of hibernation) I get the exact problem you've described above. I also tried increasing swap to something huge and it still didn't work.

But here's the odd thing: I just changed that setting to "suspend to RAM", and now it in fact hibernates just fine, in other words the screen goes blank and the hard disk stops spinning, and the light on my computer blinks, so that only the power button will wake it up again. Regardless of what it's called, that matches my definition of hibernation.

Similarly, if I go to the shutdown menu and choose "hibernate", I again get the free swap space problem described above, but if I choose "sleep" then it goes into a state that perfectly matches my definition of hibernation.

So short answer: just use "sleep" or "suspend to RAM" and pretend it's called "hibernate". You won't know the difference.

share|improve this answer
    
Some definitions here. Hibernate writes the RAM contents to disk, completely shuts down the system, and on reboot, loads from disk and into memory to restore the system to previous state. While suspend keeps everything in RAM and puts the system on a low-power mode (essentially only the RAM receives power). Two main differences: speed (resuming from suspend is much faster than restoring from hibernate) and power usage (you can potentially stay in hibernate indefinitely, as the system is powered off, but suspend will drain the battery, although very slowly). So be careful, they are different. –  roadmr Dec 16 '11 at 15:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.