Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have both operating systems installed on my PC, but Facebook only works on XP.

I have tried Firefox and Chromium, but it works the first time, but after I log in it doesn't work, and can only open the main window again after I clean up the cache.

Any ideas?

share|improve this question
    
What do you mean by does not work? –  qbi Apr 12 '11 at 6:07

4 Answers 4

"I discovered it was a problem with the MTU (maximum transmission unit), wish says the largest protocol data unit that the layer can pass onwards.

I found the answer here http://ubuntuforums.org/showthread.php?t=1376506

Hope this help others"

This helped me:

sudo ifconfig eth0 mtu 1492

ifconfig | grep MTU

Where eth0 is the type of connection that you have, and can vary from person to person.

share|improve this answer
    
In my case, the command for change MTU correct the problem. sudo ifconfig wlan0 mtu 1492 Why? –  ePhillipe Jun 10 '12 at 17:40
    
What the hell, I spent a year searching for this problem. This was problem only with a combination of some linux distributions and a home router. Every other combination of every other OS and every other router was working normally. And today I found this post and I would give you a thousands of votes up, if I could. Thank you. –  kv1dr Nov 27 '13 at 15:38

In my case, the command needed for a wireless connection works with:

sudo ifconfig wlan0 mtu 1492

:)

share|improve this answer

Make sure you are not accidentally still logged in to the account with the MS Windows session. Uncheck the checkmark that says to keep you logged in when you log into Facebook. It won't work when you use Ubuntu, because the account is being used. I have come across this many times when setting up Yahoo accounts, Facebook, etc.

I have never adjusted the MTU, it has worked just fine with the default settings...and I have set up hundreds of dual boot, and Ubuntu Only systems over the years, so that is something new and strange that Facebook would not work in Ubuntu straight out of the box. :-)

share|improve this answer
8  
That sounds like nonsense to me; I'm often signed in with several devices at the same time and it has never been a problem. –  oKtosiTe Apr 24 '11 at 9:02
    
I revised my statement to make it clearer. –  Merlin2525 Apr 24 '11 at 12:43

I think there's a problem with the permissions of your cache directory.

  1. Create a directory named cache in your home folder:

    mkdir ~/cache
    
  2. Start Chromium with --disk-cache-dir:

    chromium-browser --disk-cache-dir ~/cache
    
  3. Try to load Facebook.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.