Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed ubuntu 12.04 and 13.04 on a Dell Vostro 200. On both, my resolution is/was set at '1024 x 768'. The only other offering under settings is '800 x 600'.

Everything on the screen is too big, the resolution is too low. On WinXp/Win7/Win8 my setting are 1280 x 1024, which is perfect. How can I get my Dell Vostro 200 Ubuntu 12.04 to set the resolution to 1280 x 1024?

On some posts there is the reference to a Folder .../etc/gdm and running run -xrandr. I tried copying and pasting -xrandr strings from other posts, they did not work, and I discover that I don't have the folder ./etc/gdm on either the Ubuntu 12.04 OR 13.04 instalation.

I am only a user of the software, I have NO understanding of the mechanics of Ubuntu OR Windows. The solution needs to be straigtforward, simple, even 'child-proof', any help will be appreciated.

share|improve this question
    
Could you open a terminal and type xrandr and lspci -nnk | grep -A5 VGA edit your question and add the complete output? –  Braiam Sep 16 '13 at 18:23
    
Did you try to see if there is something listed in the "Additional Drivers" tab (in the Software & Updates application)? –  Alex Sep 16 '13 at 19:12
    
:~$ xrandr Screen 0: minimum 320 x 200, current 1024 x 768, maximum 32767 x 32767 VGA1 connected 1024x768+0+0 (normal left inverted right x axis y axis) 0mm x 0mm 1024x768 60.0* 800x600 60.3 56.2 848x480 60.0 640x480 59.9 –  user193402 Sep 18 '13 at 17:53
    
:~$ lspci -nnk | grep -A5 VGA 00:02.0 VGA compatible controller [0300]: Intel Corporation 82G33/G31 Express Integrated Graphics Controller [8086:29c2] (rev 02) Subsystem: Dell Device [1028:0238] Kernel driver in use: i915 Kernel modules: i915 00:19.0 Ethernet controller [0200]: Intel Corporation 82562V-2 10/100 Network Connection [8086:10c0] (rev 02) Subsystem: Dell Device [1028:0238] –  user193402 Sep 18 '13 at 17:54
    
I ran "Additional Drivers", there were none. –  user193402 Sep 18 '13 at 17:54
show 1 more comment

1 Answer

This occurs because the monitor has not been recognised as one able to offer the higher resolution. xrandr and its gui counterpart arandr can allow you to address these problems.

Type xrandr at the command line and you will get a list of resolution the system thinks your monitor can handle. I get something like this:

$ xrandr
Screen 0: minimum 320 x 200, current 1680 x 1050, maximum 4096 x 4096
VGA1 connected 1680x1050+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1680x1050_60.00   60.0*+
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  

if the resolution is not present three steps are reuired. First you will need to get the information required to create a command to allow you to set your new resolution. (Notice the VGA1? This is the name of the monitor...remember this for later) To do so use a command called cvt. e.g. in your case cvt 1280 1024

I get something like this: -

$ cvt 1280 1024
# 1280x1024 59.89 Hz (CVT 1.31M4) hsync: 63.67 kHz; pclk: 109.00 MHz
Modeline "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

Then you have to create a new mode for xrandr using above information...Copy and paste (Control C and Control V) sometimes does not work. highlight and middle click seems to work better.

$xrandr --newmode "1280x1024_60.00"  109.00  1280 1368 1496 1712  1024 1027 1034 1063 -hsync +vsync

and then allow this resolution to be used by VGA1 (or whatever your monitor was called) using

$ xrandr --addmode VGA1 1280x1024_60.00

To start using this newly added mode...

$ xrandr --output VGA1 --mode 1280x1024_60.00

Your computer will now be in the required resolution. If this works then you can now think of incorporating this into xorg.conf. you can also make a start up script to have the same effect. Both are described in detail in this section

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.