Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I really want to try out and become a full time user of Ubuntu on my laptop so for the moment I have setup a dual boot on my Windows 8 HP Envy M6 Laptop. To do this, I shrank my Windows 8 partition to create 100GB empty space that the Ubuntu installer could use to install itself to. I then followed these instructions with Ubuntu 13.04 x64 as my distro of choice.

http://www.makeuseof.com/tag/tired-of-windows-8-how-to-dual-boot-windows-ubuntu/

I selected the option within Ubuntu to install alongside Windows 8 at first. I then later tried the manual option to no avail.

When I restart my machine it just boots straight into Windows. The install booted up in UEFI mode absolutely fine and when I press F9 to get my boot options, Ubuntu 13.04 shows up as an option. However, selecting this option will just cause the machine to boot in Windows 8. I'm at a real loss at the moment as to what I can do as the process should not be this difficult (at least it wasn't with legacy booting) but If nobody can solve this issue it looks as if I'll have to abandon the idea of Linux altogether. Any help would be greatly appreciated.

Cheers, Jezzipin

share|improve this question
    
Is “Secure Boot” enabled in your BIOS? Try turning that off. –  U2744 SNOWFLAKE Sep 16 '13 at 14:19
    
I thought Ubuntu is supposed to be able to deal with 'Secure boot' –  jezzipin Sep 16 '13 at 14:25
    
Could be, but give it a try. It’s also mentioned in the “Troubleshooting” section of that article. –  U2744 SNOWFLAKE Sep 16 '13 at 14:27

1 Answer 1

First, try disabling Secure Boot, if you haven't done so already. This feature can sometimes cause this symptom. If that fails, be aware that HPs are known to have buggy EFIs that make dual-booting difficult. Some things you can try:

  • Check with HP to see if there's a firmware update for your computer. If there is one, install it. You may also need to re-install GRUB after you update the firmware.
  • Return the computer to the store and buy another brand. This is my #2 suggestion because the problem has existed for months and HP doesn't seem to have lifted a finger to change it. (#1 exists to give HP the benefit of the doubt; maybe they have fixed it, and I simply haven't heard of it yet.) This behavior calls out for action that will get HP's attention, and the best action to take to get the attention of a company is to return their problem products.
  • In Windows, open an Administrator Command Prompt window and type bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi (change grubx64.efi to shimx64.efi if you're booting with Secure Boot active). This method works on some computers with similar problems, but usually not on HPs. Still, it's worth trying.
  • Prepare a USB flash drive with rEFInd and test it. If it boots both Linux and Windows, reconfigure your firmware to boot from the USB flash drive by default and leave the rEFInd flash drive inserted in the computer.
  • Run Boot Repair on the system, select the Advanced option, and click the check box to back up and replace the Windows boot files. This will cause GRUB to be installed in place of the Windows boot loader, and GRUB will be reconfigured to launch the Windows boot loader under its own name. This solution is an ugly hack, and some users have reported that Windows will sometimes undo it, so it's not really a reliable long-term solution.
  • Install GRUB, rEFInd, or some other boot manager as EFI/BOOT/bootx64.efi on the ESP (that is, as /boot/efi/EFI/BOOT/bootx64.efi) and move or rename the EFI/Microsoft/Boot/bootmgfw.efi file to some other location. With any luck, your target boot loader will then launch. If you use GRUB, you'll need to reconfigure it to find the Windows boot loader wherever you moved it. If you use rEFInd, it will detect the Windows boot loader if you move it to the EFI/Microsoft directory.
share|improve this answer
    
Disabling secure boot did it. I don't have an option pop-up that enables me to select between Windows 8 and Ubuntu but if I press f9 on startup and I get a change boot order screen that will now allow me to select Ubuntu –  jezzipin Sep 18 '13 at 14:37
    
Trying the other options may enable you to get to your desired boot manager without having to hit F9 when you boot. –  Rod Smith Sep 18 '13 at 17:20
    
I can't take this back to the store as I have had it for some time. Also it is a very decent machine and the build quality is excellent so taking the machine back just because HP's support for a fringe operating system is lacking is not a viable option in my book. –  jezzipin Sep 19 '13 at 16:14
    
Taking it back was not the only option I provided; however, I take issue with the claim that the problem is with "support for a fringe operating system." That's not the problem; the problem is that their EFI implementation violates the EFI standard. If Microsoft should decide to change the filename of its boot loader in the future, the HP you have now will stop booting Windows. If Linux becomes more popular in the future, the "fringe" argument will go away. It's not a question of support; it's a question of following standards, which HP has not done. –  Rod Smith Sep 19 '13 at 17:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.