Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I accidently installed connmanager, it removed my network-manager and network-manager-gnome. Now I cannot connect to my wifi and ethernet connection. I tried to install network-manager from source (latest version) but it had dependency issues. Now when I am connecting internet through usb-modem. but still I cannot install network-manager and network-manager-gnome using apt-get -f it shows the following error:

apt-get -f install network-manager network-manager-gnome

Reading package lists... Done
Building dependency tree       
Reading state information... Done

network-manager is already the newest version.
The following package was automatically installed and is no longer required:
  libllvm2.8
Use 'apt-get autoremove' to remove them.

Suggested packages:
  network-manager-openvpn-gnome network-manager-vpnc-gnome
The following packages will be upgraded:
  network-manager-gnome
1 upgraded, 0 newly installed, 0 to remove and 728 not upgraded.
1 not fully installed or removed.
Need to get 0 B/404 kB of archives.
After this operation, 3,214 kB disk space will be freed.
Do you want to continue [Y/n]? y

dpkg: dependency problems prevent configuration of network-manager-gnome:
 network-manager-gnome depends on libgnome-bluetooth7 (>= 2.27.8); however:
  Package libgnome-bluetooth7 is not installed.

 network-manager-gnome depends on libnm-glib2 (>= 0.8~rc2~git.20091229t135236.302e62d); however:
  Package libnm-glib2 is not installed.

 network-manager-gnome depends on libnm-util1 (>= 0.8~a~git.20090930t162132.866d48b); however:
  Package libnm-util1 is not installed.

 network-manager-gnome depends on libnotify1 (>= 0.4.5); however:
  Package libnotify1 is not installed.

 network-manager-gnome depends on libnotify1-gtk2.10; however:
  Package libnotify1-gtk2.10 is not installed.
 network-manager (0.9.4.0-0ubuntu4.3) breaks network-manager-gnome (<< 0.8.99) and is installed.
  Version of network-manager-gnome to be configured is 0.8-0ubuntu3.1.

 libnm-gtk0 (0.9.4.1-0ubuntu2) breaks network-manager-gnome (<< 0.9.1.90-0ubuntu2) and is installed.

  Version of network-manager-gnome to be configured is 0.8-0ubuntu3.1.
 gnome-bluetooth (3.2.2-0ubuntu5) breaks network-manager-gnome (<< 0.9.0-3) and is installed.

 Version of network-manager-gnome to be configured is 0.8-0ubuntu3.1.
 libnm-gtk-common (0.9.4.1-0ubuntu2) breaks network-manager-gnome (<< 0.9.1.90-0ubuntu2) and is installed.

  Version of network-manager-gnome to be configured is 0.8-0ubuntu3.1.
dpkg: error processing network-manager-gnome (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                           Errors were encountered while processing:
 network-manager-gnome
E: Sub-process /usr/bin/dpkg returned an error code (1)

And ifconfig shows:

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:152 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:12592 (12.5 KB)  TX bytes:12592 (12.5 KB)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:100.101.120.10  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:12852 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12958 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:10903035 (10.9 MB)  TX bytes:1972515 (1.9 MB)

How can I revert my system back?

I am using Ubuntu 12.04 32-bit.

share|improve this question
    
Could you edit your question and add sudo apt-get check? And apt-cache policy network-manager-gnome –  Braiam Sep 16 '13 at 23:04

1 Answer 1

What is dependency for libnotify1 ? Try sudo apt-get install libnotify1. Do the same for libgnome-bluetooth7, libnm-glib2, libnm-util1

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.