Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a sony vaio laptop with a gpu ati mobility hd4650, and i want to install fglrx drivers but every time i try to do so i get an error. The title of the error is: fglrx kernel failed to build. The fglrx.0.crash is the following:

ProblemType: Package
DKMSBuildLog:
DKMS make.log for fglrx-8.960 for kernel 3.8.0-30-generic (i686)
Mon Sep 16 14:06:37 EEST 2013
AMD kernel module generator version 2.1
kernel includes at /lib/modules/3.8.0-30-generic/build/include not found or incomplete
file: /lib/modules/3.8.0-30-generic/build/include/linux/version.h
DKMSKernelVersion: 3.8.0-30-generic
Date: Mon Sep 16 14:06:43 2013
DuplicateSignature:
 DKMS make.log for fglrx-8.960 for kernel 3.8.0-30-generic (i686)
 AMD kernel module generator version 2.1
 kernel includes at /lib/modules/3.8.0-30-generic/build/include not found or incomplete
 file: /lib/modules/3.8.0-30-generic/build/include/linux/version.h

FglrxBuildLog:
 AMD kernel module generator version 2.1
 .
 Active kernel:
 uname -a = Linux kormoranos-VGN-FW41M-H 3.8.0-30-generic #44~precise1-Ubuntu SMP Fri Aug 23 17:33:45 UTC 2013 i686 i686 i386 GNU/Linux
 uname -s = Linux
 uname -m = i686
 uname -r = 3.8.0-30-generic
 uname -v = #44~precise1-Ubuntu SMP Fri Aug 23 17:33:45 UTC 2013
 .
 Target kernel:
 uname -a = Linux kormoranos-VGN-FW41M-H 3.8.0-30-generic #44~precise1-Ubuntu SMP Fri Aug 23 17:33:45 UTC 2013 i686 i686 i386 GNU/Linux
 uname -s = Linux
 uname -m = i686
 uname -r = 3.8.0-30-generic
 uname -v = #44~precise1-Ubuntu SMP Fri Aug 23 17:33:45 UTC 2013
 .
 kernel includes at /lib/modules/3.8.0-30-generic/build/include not found or incomplete
 file: /lib/modules/3.8.0-30-generic/build/include/linux/version.h
Package: fglrx
PackageVersion: 2:8.960-0ubuntu1.1
SourcePackage: fglrx-installer
Title: fglrx 2:8.960-0ubuntu1.1: fglrx kernel module failed to build
ApportVersion: 2.0.1-0ubuntu17.4
Architecture: i386
Dependencies:
 adduser 3.113ubuntu2
 base-passwd 3.5.24
 binutils 2.22-6ubuntu1.1
 busybox-initramfs 1:1.18.5-1ubuntu4.1
 coreutils 8.13-3ubuntu3.2
 cpio 2.11-7ubuntu3
 cpp 4:4.6.3-1ubuntu5
 cpp-4.6 4.6.3-1ubuntu5
 debconf 1.5.42ubuntu1
 debianutils 4.2.1ubuntu2
 dkms 2.2.0.3-1ubuntu3.1
 dpkg 1.16.1.2ubuntu7.1 [modified: sbin/start-stop-daemon]
 findutils 4.4.2-4ubuntu1
 fontconfig 2.8.0-3ubuntu9.1
 fontconfig-config 2.8.0-3ubuntu9.1
 gcc 4:4.6.3-1ubuntu5
 gcc-4.6 4.6.3-1ubuntu5
 gcc-4.6-base 4.6.3-1ubuntu5
 ifupdown 0.7~beta2ubuntu8
 initramfs-tools 0.99ubuntu13.2
 initramfs-tools-bin 0.99ubuntu13.2
 initscripts 2.88dsf-13.10ubuntu11.1
 insserv 1.14.0-2.1ubuntu2
 iproute 20111117-1ubuntu2
 keyboard-configuration 1.70ubuntu5
 klibc-utils 1.5.25-1ubuntu2
 libacl1 2.2.51-5ubuntu1
 libattr1 1:2.4.46-5ubuntu1
 libaudio2 1.9.3-4
 libblkid1 2.20.1-1ubuntu3
 libbz2-1.0 1.0.6-1
 libc-bin 2.15-0ubuntu10.4
 libc6 2.15-0ubuntu10.4
 libdb5.1 5.1.25-11build1
 libdbus-1-3 1.4.18-1ubuntu1.4
 libdrm-intel1 2.4.43-0ubuntu0.0.2
 libdrm-nouveau1a 2.4.43-0ubuntu0.0.2
 libdrm-radeon1 2.4.43-0ubuntu0.0.2
 libdrm2 2.4.43-0ubuntu0.0.2
 libexpat1 2.0.1-7.2ubuntu1.1
 libffi6 3.0.11~rc1-5
 libfontconfig1 2.8.0-3ubuntu9.1
 libfontenc1 1:1.1.0-1
 libfreetype6 2.4.8-1ubuntu2.1
 libgcc1 1:4.6.3-1ubuntu5
 libgcrypt11 1.5.0-3ubuntu0.2
 libglib2.0-0 2.32.3-0ubuntu1
 libgmp10 2:5.0.2+dfsg-2ubuntu1
 libgomp1 4.6.3-1ubuntu5
 libgpg-error0 1.10-2ubuntu1
 libice6 2:1.0.7-2build1
 libjpeg-turbo8 1.1.90+svn733-0ubuntu4.1
 libjpeg8 8c-2ubuntu7
 libklibc 1.5.25-1ubuntu2
 liblcms1 1.19.dfsg-1ubuntu3
 liblocale-gettext-perl 1.05-7build1
 liblzma5 5.1.1alpha+20110809-3
 libmng1 1.0.10-3
 libmount1 2.20.1-1ubuntu3
 libmpc2 0.9-4
 libmpfr4 3.1.0-3ubuntu2
 libncurses5 5.9-4
 libncursesw5 5.9-4
 libnih-dbus1 1.0.3-4ubuntu9.1
 libnih1 1.0.3-4ubuntu9.1
 libpam-modules 1.1.3-7ubuntu2
 libpam-modules-bin 1.1.3-7ubuntu2
 libpam0g 1.1.3-7ubuntu2
 libpciaccess0 0.12.902-1ubuntu0.2
 libpcre3 8.12-4
 libpixman-1-0 0.24.4-1
 libplymouth2 0.8.2-2ubuntu31.1
 libpng12-0 1.2.46-3ubuntu4
 libqt4-dbus 4:4.8.1-0ubuntu4.4
 libqt4-declarative 4:4.8.1-0ubuntu4.4
 libqt4-network 4:4.8.1-0ubuntu4.4
 libqt4-script 4:4.8.1-0ubuntu4.4
 libqt4-sql 4:4.8.1-0ubuntu4.4
 libqt4-xml 4:4.8.1-0ubuntu4.4
 libqt4-xmlpatterns 4:4.8.1-0ubuntu4.4
 libqtcore4 4:4.8.1-0ubuntu4.4
 libqtgui4 4:4.8.1-0ubuntu4.4
 libquadmath0 4.6.3-1ubuntu5
 libselinux1 2.1.0-4.1ubuntu1
 libslang2 2.2.4-3ubuntu1
 libsm6 2:1.2.0-2build1
 libstdc++6 4.6.3-1ubuntu5
 libtiff4 3.9.5-2ubuntu1.5
 libtinfo5 5.9-4
 libudev0 175-0ubuntu9.4
 libuuid1 2.20.1-1ubuntu3
 libx11-6 2:1.4.99.1-0ubuntu2.2
 libx11-data 2:1.4.99.1-0ubuntu2.2
 libxau6 1:1.0.6-4
 libxaw7 2:1.0.9-3ubuntu1
 libxcb1 1.8.1-1ubuntu0.2
 libxcursor1 1:1.1.12-1ubuntu0.1
 libxdmcp6 1:1.1.0-4
 libxext6 2:1.3.0-3ubuntu0.1
 libxfixes3 1:5.0-4ubuntu4.1
 libxfont1 1:1.4.4-1
 libxi6 2:1.6.0-0ubuntu2.1
 libxinerama1 2:1.1.1-3ubuntu0.1
 libxkbfile1 1:1.0.7-1ubuntu0.1
 libxmu6 2:1.1.0-3
 libxpm4 1:3.5.9-4
 libxrandr2 2:1.3.2-2ubuntu0.2
 libxrender1 1:0.9.6-2ubuntu0.1
 libxt6 1:1.1.1-2ubuntu0.1
 libxxf86vm1 1:1.1.1-2ubuntu0.1
 linux-headers-3.2.0-53 3.2.0-53.81
 linux-headers-3.2.0-53-generic 3.2.0-53.81
 linux-headers-generic 3.2.0.53.63
 linux-libc-dev 3.2.0-53.81
 lsb-base 4.0-0ubuntu20.3
 make 3.81-8.1ubuntu1.1
 makedev 2.3.1-89ubuntu2
 module-init-tools 3.16-1ubuntu2
 mount 2.20.1-1ubuntu3
 mountall 2.36.4
 multiarch-support 2.15-0ubuntu10.4
 ncurses-bin 5.9-4
 passwd 1:4.1.4.2+svn3283-3ubuntu5.1
 patch 2.6.1-3
 perl-base 5.14.2-6ubuntu2.3
 plymouth 0.8.2-2ubuntu31.1
 procps 1:3.2.8-11ubuntu6
 sed 4.2.1-9
 sensible-utils 0.0.6ubuntu2
 sysv-rc 2.88dsf-13.10ubuntu11.1
 sysvinit-utils 2.88dsf-13.10ubuntu11.1
 tar 1.26-4ubuntu1
 ttf-dejavu-core 2.33-2ubuntu1
 tzdata 2013d-0ubuntu0.12.04
 ucf 3.0025+nmu2ubuntu1
 udev 175-0ubuntu9.4
 upstart 1.5-0ubuntu7.2 [modified: sbin/initctl]
 util-linux 2.20.1-1ubuntu3
 x11-common 1:7.6+12ubuntu2
 x11-xkb-utils 7.6+4
 xkb-data 2.5-1ubuntu1.3
 xserver-common 2:1.11.4-0ubuntu10.13
 xserver-xorg-core 2:1.11.4-0ubuntu10.13
 xz-utils 5.1.1alpha+20110809-3
 zlib1g 1:1.2.3.4.dfsg-3ubuntu4
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.04.3 LTS "Precise Pangolin" - Release i386 (20130820.1)
MarkForUpload: True
PackageArchitecture: i386
ProcVersionSignature: Ubuntu 3.8.0-30.44~precise1-generic 3.8.13.6
Tags:  precise ubuntu
Uname: Linux 3.8.0-30-generic i686
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: No upgrade log present (probably fresh install)

I also tried to install the drivers from amd website but again i get an error. Is there anything i can do about it???

share|improve this question
add comment

1 Answer

Same for me installing with kernel 3.8.0-33-generic using the amd-driver-installer-catalyst-13.1-legacy-linux-x86.x86_64.run - from the ATI website - to make Ubuntu AMD64 deb packages to install. They appear to make but DKMS produces a "make.log" with content AMD kernel module generator version 2.1 kernel includes at /lib/modules/3.8.0-33-generic/build/include not found or incomplete when using dpkg to install the deb files. From what I can tell this may be because the .run file only works with earlier kernels (eg) - but that seems wrong to me as surely that would be the first thing to test in the .run script ...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.