Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two monitors. I am very particular as to which window goes to which monitor (e.g. Firefox always on the left side; terminals on other workspaces always maximized on the left monitor; R graphics always on the right monitor etc.).

I use the scale plugin with the "initiate window picker for all windows" binding to switch between windows. I also use the option "use device with pointer" of the "place windows" plugin (that way, when opening a window, it goes to the monitor that I want it to go; however, the behavior I'm about to describe happens also when the option "use active device" is selected).

However, often when I use the scale plugin to jump between windows placed on different workspaces, it jumps from one monitor to the other. Most frequently it moves from the monitor on the left hand side to the monitor on the right. It annoys the hell out of me, because I then feel compelled to drag the window back to the left side. It never happens if I do not switch between workspaces.

I think it might be due to the "place windows" options and the "scale" plugin options that I use together. You see, when I initiate window picker for all windows, most of the windows, for some reason, get minimized on the right hand monitor, like this:

enter image description here

Then when I select one of the windows on the right, the cursor is on the right hand side of the screen; and so maybe the "place window" plugin gets called and puts the window there (because it is both, the active device and the device with the cursor). So here is a before calling window picker and after calling window picker screenshot:

Before:

enter image description here

Then I use window picker to switch to a window on another workspace, and again to switch back to the initial workspace with the firefox window:

After:

enter image description here

Question: What can I do to prevent this behavior? I mean, apart from using window picker for all workspaces.

share|improve this question
    
I'm having the same problem. My windows even jump to different workspaces. Did you find a solution? –  iamnotmaynard Jun 25 at 18:33

2 Answers 2

I have a suggestion you might try. Launch Compiz, go to Windows Management, and click on Scale then click on the Behaviour tab.

Check to see what your setting for "Multi Output Mode" is. Try setting it to "On current output device" and see if that helps any...

enter image description here

I hope this helps... Good Luck!

share|improve this answer
    
I'm sorry, but no :-( Still the same. However, +1 because it falsifies my hypothesis. Since the window miniatures are now on the left (active) device, as is the pointer, and since the Firefox (or another) window jumps to the right (inactive) device when switching to that desktop, it probably doesn't have anything to do with window placement and pointer position. –  January Sep 27 '13 at 9:13

I was able to remedy this by opening General->Display Settings in CCSM and changing "Overlapping Output Handling" to anything other than "Smart".

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.