Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Steam just stopped to work. It worked fine until a couple of days ago, but now it won't launch. I've tried both to restart the computer and reinstall Steam, but it makes no difference. When I tried to launch it from the console I get only this:

marc@marc-UX21E:~$ steam
Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically

Any idea about what may it be?

Thank you.

EDIT: I have tried to launch it after a computer restart and got some kind of error after trying to update Steam:

Running Steam on ubuntu 13.04 32-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
unlinked 0 orphaned pipes
Gtk-Message: Failed to load module "overlay-scrollbar"
Installing breakpad exception handler for appid(steam)/version(1378500910_client)
[0916/102432:WARNING:proxy_service.cc(958)] PAC support disabled because there is no system implementation
share|improve this question

2 Answers 2

up vote 0 down vote accepted

I had the same problem (not sure about the 'after restart' part, though). Steam would start then exit without printing an error. I asked a question about it here.

The solution which worked for me was

  1. Remove Steam with this

    sudo apt-get remove steam*
    
  2. Remove everything from the ~/.local/share/Steam folder except SteamApps

  3. Reinstall Steam with this

    sudo apt-get install steam-launcher
    

Credits to Rat2000 for his answer here

Note: I had used the Steam .deb file from the official website and so had the Steam repo enabled

share|improve this answer
    
I am installing it right now, I hope it works. Thank you very much! –  user1897262 Sep 16 '13 at 8:42
    
It worked! Thanks a lot! –  user1897262 Sep 16 '13 at 9:14

I had the same problem with Steam on ubuntu 12.04 64 bit. I ended up doing a clean reinstall of ubuntu, since I was already considering it for a while.

What happens if you go on a terminal and type STEAM_RUNTIME=0 steam ? I read somewhere that this worked for some people. If it tells you that libraries are missing, you might want to try typing sudo apt-get install ia32-libs and see how that goes.

If that doesn't work either, then you're in the same situation as me. For me, however, a clean install of ubuntu fixed it.

share|improve this answer
    
I have already tried the STEAM_RUNTIME=0 and got the same result, only saying that this was disabled by the user. I'll try to fix it in some other way, but if I can't I'll reinstall Ubuntu. Thank you very much! –  user1897262 Sep 16 '13 at 8:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.