Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The problem I'm experiencing is losing the Windows 8 session after sleep/hibernate.

When resuming the session I would expect to load directly into Windows, however the GRUB bootloader displays. At this point I select the Windows bootloader and it starts a new session as though Windows has restarted.

Any suggestions?

System setup: Dual boot Ubuntu 12.04 and Windows 8 using GRUB 1.99 bootloader.

share|improve this question
add comment

2 Answers 2

I've encountered the same and have stumbled upon a solution.

For Windows to Sleep/Hibernate, the 1st Windows Disk Usually the "C:\" needs be tagged as "Bootable". Or if you had a Pre-installed disk with your system, you should mark the "Boot" partition as "Boot" disk. This can be easily done using Gparted.

share|improve this answer
add comment
up vote 1 down vote accepted

Using GParted swap the boot flag from /boot/efi partition to the first Windows partition sda1 allowed the hibernate session to start properly. In this case, the Windows Recovery was the first partition.

Since GRUB is installed in the MBR. Setting the flag will not disrupt the GRUB boot loader sequence.

Other solutions are posted here: http://ubuntuforums.org/showthread.php?t=1341694

Also, check if your BIOS has a sleep mode, after turning this feature off the the system boots into the lasted used OS.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.