Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

PROBLEM I am getting SATA Errors which is causing my RAID6 Array to fail (degrade).

This started happening after I recently replaced my (MSI) motherboard with an ASUS M5A97 R2.0 motherboard.

Is there any way to fix or work around this bug?

CONFIGURATION Ubuntu 12.04.3 LTS Server. Using six Seagate 3TB drives (ST3000DM001) set up as a 5 drive RAID 6 (and 1 cold spare). The drives have 4 primary partitions (bios_grub, two raid, and swap). There are two RAID6 arrays, md0 is 1G for /boot and md1 is 2.7T cut up via LVM for the system and data storage.

BACKGROUND This was working fine for a couple of years. Because of a motherboard failure I changed to an ASUS motherboard. After installing the new motherboard, I get the errors below and my RAID array goes into State : clean, degraded. I have tried removing and adding (via re-add and add) /dev/sde3 into md1 and it always fails in a few seconds. Using the cold spare to replace the drive resulted in the same errors. I have also tried changing the SATA cables and SATA port. It seems that I have the same issue in both port 5 and port 6. Is there a difference in the controller between ports 1-4 and ports 5-6?

Searching the web for these errors show lots of people having this issue with various linux distros and laying the blame on everything from faulty SATA cables to NVIDIA drivers. The most promising thing I turned up was a Red Hat bug report Bug 611350 (https://bugzilla.redhat.com/show_bug.cgi?id=611350) from 2010. The exact error was seen by many with Fedora 13. Some reported success with adding "pcie_aspm=off" to the boot options, and the bug was closed with the release of Fedora 15 which solved the issue for the user. This seems to suggest that there is a bug fix that could be applied to Ubuntu.


kernel:  ata5.00: exception Emask 0x10 SAct 0x1 SErr 0x400000 action 0x6 frozen
kernel:  ata5.00: irq_stat 0x08000000, interface fatal error
kernel:  ata5: SError: { Handshk }
kernel:  ata5.00: failed command: WRITE FPDMA QUEUED
kernel:  ata5.00: cmd 61/10:00:e0:58:bc/00:00:01:00:00/40 tag 0 ncq 8192 out
kernel:           res 40/00:00:e0:58:bc/00:00:01:00:00/40 Emask 0x10 (ATA bus error)
kernel:  ata5.00: status: { DRDY }
kernel:  ata5: hard resetting link
kernel:  ata5: SATA link up 6.0 Gbps (SStatus 133 SControl 300)

 # mdadm --detail /dev/md1
         Version : 1.2
   Creation Time : Thu Mar 21 14:31:23 2013
      Raid Level : raid6
      Array Size : 8757904896 (8352.19 GiB 8968.09 GB)
   Used Dev Size : 2919301632 (2784.06 GiB 2989.36 GB)
    Raid Devices : 5
   Total Devices : 5
     Persistence : Superblock is persistent

     Update Time : Sun Sep 15 21:24:53 2013
           State : clean, degraded
  Active Devices : 4
 Working Devices : 4
  Failed Devices : 1
   Spare Devices : 0

          Layout : left-symmetric
      Chunk Size : 512K

            Name : cathal:1
            UUID : 00588a3b:ddb88169:aea236fa:a1bcf53d
          Events : 50236

     Number   Major   Minor   RaidDevice State
        0       8        3        0      active sync   /dev/sda3
        1       8       19        1      active sync   /dev/sdb3
        2       8       35        2      active sync   /dev/sdc3
        3       0        0        3      removed
        4       8       51        4      active sync   /dev/sdd3

        5       8       67        -      faulty spare   /dev/sde3


  • AUSU M5A97 R2.0
  • BIOS 1903 07-11-2013 (old 1503 01-16-2013)
  • AMD SB950 SATA Controller - 6x SATA 6GB/s
  • Realtek 8111F - 1 GigE LAN
  • AMD FX-6350 6 Core Processor
  • six Seagate 3TB drives (ST3000DM001)
share|improve this question
Did you try the pcie_aspm=off? The errors certainly do indicate either a cable or controller problem. –  psusi Sep 16 '13 at 2:26
I will try pcie_aspm=off later today. I don't think it is a cable issue as I have tested with two new SATA cables. Since it was apparently resolved by some change between Fedora 13 and Fedora 15, I would think it is a bug that they fixed. How do we go about finding the change and getting it patched into Ubuntu? –  MERM Sep 16 '13 at 13:43
That depends entirely on whether or not you are having the same issue, which depends on whether or not the pcie_aspm=off works. –  psusi Sep 16 '13 at 13:45
Also the problem supposedly went away long ago ( in 2.6.x, 12.04 is using 3.x ), so I think you're issue is unrelated. –  psusi Sep 16 '13 at 13:52
I tried pcie_aspm=off, to no avail. The problem persists. –  MERM Sep 16 '13 at 21:58

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.