Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I am using ubuntu 11.10 version .. when I try to open the ubuntu software center it opens but gives me a blank screen and nothing shows up , before this happens it used to open normally but I couldn't install or upgrade anything from it as an error used to pop up that I have to remove something and it also refused to remove it ! so please I need a solution for this .

share|improve this question

marked as duplicate by Eric Carvalho, mikewhatever, Mateo, Mitch, Kevin Bowen Sep 16 '13 at 4:10

This question was marked as an exact duplicate of an existing question.

    
open up a terminal and launch software-center from there. Hopefully, you will see some error output. Either that will already help you solving your problem or you can paste it here. – onse Sep 15 '13 at 22:01
    
I launched it and the same thing happened again , a blank screen and nothing more – Shrouk Sep 15 '13 at 22:08
    
no there it actually opens and fails to install but mine doesn't open in the first place . – Shrouk Sep 15 '13 at 22:16

Try reinstalling it. Try this instead:

  1. Open Terminal
  2. type sudo apt-get install --reinstall software-center

Do not try opening it from terminal. You're just doing more work.

I had this problem many times and I tried doing so many things and none of them worked.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.