Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I clear the recently used and viewed files in ubuntu 11.04 without using terminal?

share|improve this question
1  
What's wrong with the terminal? You can always create a graphical shortcut for a terminal command. –  Adam Byrtek Apr 11 '11 at 21:29
3  
Well we linux fans wouldn't mind...but new users migrating from other OS might prefer a GUI method to clear recently viewed files. –  nik90 Apr 11 '11 at 21:30
3  
on ubuntu 10.10 you have an option in the menu for that. i think it is faster and easier to use via gui –  Pascal Apr 11 '11 at 21:35
add comment

13 Answers 13

up vote 5 down vote accepted

The only way I know how to do this is to install Ubuntu Tweak, which can be found by going to http://ubuntu-tweak.com/ and installing the software.

Open Ubuntu Tweak up and go to Gnome Settings then uncheck Enable System Wide "Recent Documents" List

share|improve this answer
    
thanks for the answer. i tried to install ubuntu tweaks a few days ago but it requires python <2.7 and 2.7.1 is part of natty. so i have to wait for an update –  Pascal Apr 12 '11 at 7:21
    
launchpad.net/~tualatrix/+archive/ppa is the Ubuntu Tweak PPA which will install for you without any unmet dependency problems happening. –  scouser73 Apr 14 '11 at 16:59
    
This solution no longer works. I'm on Classic desktop and unticked the option as I usually did after a fresh install, but recent documents keeps accumulating. –  Oxwivi May 14 '11 at 5:35
add comment

It depends on whether you're using Unity or the Classic desktop.

In Unity, the recent documents that you see in the Files lens are logged using Zeitgeist. If you don't want to use the terminal to remove these, or only want to remove a few of them, the best thing to do is install "Activity Journal" using the Software Center. Fire up the Activity Journal, and you'll see all your recently used apps and documents, grouped by day. If you right click a document and click "Delete item from Journal", Zeitgeist will forget that you used that document at that specific time. If you click "Delete all items with this URL", Zeitgeist will forget you ever used that document. If you want to delete everything, this terminal command (which others have already posted) will do the job:

rm ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace

There's a Zeitgeist Global Privacy app in development which will make this easier, but unfortunately it's not released yet.

The Classic desktop (and the lists of recently used files in most applications' File menus) stores a record of your recently used documents in ~/.local/share/recently-used.xbel. You can just delete this file using the file manager or copy and paste the following code into a terminal:

rm ~/.local/share/recently-used.xbel

Hope that helps!

share|improve this answer
add comment

Run the following command in your terminal:

rm ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace
share|improve this answer
add comment

Upgrade to 12.04. It by default have a cleaner and settings wizard.

Under System Settings click Privacy, there is an option to clear recent history.

share|improve this answer
    
Clarify your answer with screenshots –  Tachyons Apr 28 '12 at 3:22
add comment

you can use bleachbit go to http://bleachbit.sourceforge.net/

or install it from software center.

you will find it is a good tool

it can delete all unnecessary files too, and system cache

use as:-

open bleachbit and then check your preferences

for deleting resent documents check only

system>resentdocuments

share|improve this answer
add comment

This is what works for me, DISABLING ALL LOGGING.

Copy these three lines to a blank text file:

CREATE TRIGGER IF NOT EXISTS no_logging_uri AFTER INSERT ON uri BEGIN DELETE FROM uri ;  END;
CREATE TRIGGER IF NOT EXISTS no_logging_event AFTER INSERT ON event BEGIN DELETE FROM event ;  END;
CREATE TRIGGER IF NOT EXISTS no_logging_text AFTER INSERT ON text BEGIN DELETE FROM text ;  END;

Let's suppose you named the file as triggers.sql. The next thing to do is apply these triggers on the activity database:

$ cat triggers.sql | sqlite3 ~/.local/share/zeitgeist/activity.sqlite

If you want to restore the standard functionality simply remove the database (it will be recreated without the triggers):

$ rm ~/.local/share/zeitgeist/activity.sqlite
share|improve this answer
    
Sorry for missing the part "without using the terminal" :) –  dschulz Jan 24 '12 at 18:31
add comment
rm ~/.local/share/zeitgeist/activity.sqlite
echo -n > ~/.local/share/zeitgeist/activity.sqlite
sudo chattr -i ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace
share|improve this answer
add comment

First, you run this command on your Terminal:

rm ~/.local/share/zeitgeist/activity.sqlite

Then, you can log out and log in again, or run this command on your Terminal:

zeitgeist-daemon --replace

It's works correctly.

share|improve this answer
add comment

remove all children of xml file ~/.local/share/recently-used.xbel

<?xml version="1.0" encoding="UTF-8"?>
<xbel version="1.0"
      xmlns:bookmark="http://www.freedesktop.org/standards/desktop-bookmarks"
      xmlns:mime="http://www.freedesktop.org/standards/shared-mime-info"
/>

and

$ sudo chattr +i ~/.local/share/recently-used.xbel

to make it immutable. drop all event item in sqlite3 database and also make it immutable.

$ sqlite3 ~/.local/share/zeitgeist/activity.sqlite
sqlite> delete from event;
$ sudo chattr +i ~/.local/share/zeitgeist/activity.sqlite
share|improve this answer
add comment

Press Alt+F1 > Places > Recent Documents > Clear recent documents. I did this in Ubuntu 10.04.

share|improve this answer
add comment
rm ~/.local/share/recently-used.xbel

Then

mkdir ~/.local/share/recently-used.xbel

It will never add to the recent documents list again.

share|improve this answer
1  
-1, this doesn't fit the criteria of the question. –  jrg May 2 '12 at 11:13
add comment

To empty the file:

touch ~/.local/share/recently-used.xbel

Then, make the file immutable:

chattr +i ~/.local/share/recently-used.xbel

That will do the trick.

share|improve this answer
add comment
rm ~/.local/share/zeitgeist/activity.sqlite
zeitgeist-daemon --replace

this will do

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.