Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed Ubuntu 12.04 64bit version alongside Windows 7 64bit from DVD following the instructions on THIS page. The entire installation went as described and there seemed to be no problems with it. When I restarted I discovered there was no boot menu. I solved the problem as described on THIS link. After rebooting again I got to the boot menu and chose the Ubuntu 12.04 option after which a black screen appeared with text:

Initializing variable space.
Starting cmain()..._

and after that nothing happens except that the dash blinks. It seems that I can't provoke any kind of response with enter space or any F keys. Here is a detailed report from EasyBCD if it's of any help:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Ubuntu 12.04
BCD ID: {b25a01ae-0cc9-11e3-bbfd-742f68d47a13}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr

Windows Boot Manager
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=\Device\HarddiskVolume1
description             Windows Boot Manager
locale                  hr-HR
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {e7a07940-8e20-11e1-a7a0-b36feede8885}
resumeobject            {e7a0793f-8e20-11e1-a7a0-b36feede8885}
displayorder            {e7a07940-8e20-11e1-a7a0-b36feede8885}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10

Windows Boot Loader
identifier              {e7a07940-8e20-11e1-a7a0-b36feede8885}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Windows 7
locale                  hr-HR
inherit                 {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
recoverysequence        {e7a07941-8e20-11e1-a7a0-b36feede8885}
recoveryenabled         Yes
osdevice                partition=C:
systemroot              \Windows
resumeobject            {e7a0793f-8e20-11e1-a7a0-b36feede8885}
nx                      OptIn

Real-mode Boot Sector
identifier              {b25a01ae-0cc9-11e3-bbfd-742f68d47a13}
device                  partition=C:
path                    \NST\AutoNeoGrub0.mbr
description             Ubuntu 12.04

Any kind of help is appreciated.

share|improve this question
up vote 3 down vote accepted

It seems to me you never install GRUB2 to MBR. EasyBCD is just a windows like bootloader. When you choose the ubuntu option in easyBCD it just sends you through to GRUB2, which it seems you didn't install. You need to reinstall GRUB2

share|improve this answer
I've used Boot-Repair Disk and the Default Repair options I found on here: link. And now it seems to work just fine. It boots into Ubuntu boot selection and from there all options seem to work. Thanks a bunch! – ljetibo Sep 15 '13 at 20:38
no problem. Please close the question and if you want give me a vote :D – Harmend Jan 30 '14 at 20:31

I had exactly the same problem, but with OpenSuse. I had a dualboot and use easybcd. It loads the easybcd first then grub2.

As suggested by other that grub could be missing so I load the windows and checked the boot entry of my linux.

The location of partition was stlet to "auto locate at boot". After I changed it to the correct partition, problem was solved. ..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.