Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to correctly enable Desktop Cube in Unity 3D?

I'm looking to get the "3D Cube" in Ubuntu 11.04 Beta 1, however last time I tried it after using compiz I lost my desktop and hand to reinstall. However I have read this bug which seems to state this is fixed, however when I go to disable the wall to enable the cube it still seems like its going to break it ( I dont want to try it again as it may break my desktop again :-) )

Anyone able to shed any light on how I go about this?

share|improve this question

marked as duplicate by Luis Alvarado, Ringtail, hhlp, fossfreedom Nov 29 '12 at 9:31

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4 Answers 4

that should solve the problem: http://www.omgubuntu.co.uk/2011/04/compiz-cube-natty/

share|improve this answer
1  
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Jorge Castro Apr 12 '11 at 14:07

There are currently two issues:

  1. Every time you enable or disable a plugin in CompizConfig Settings Manager (ccsm), Compiz (and therefore Unity) will crash.
  2. CompizConfig Settings Manager fails to replace the Wall plugin with the Desktop Cube plugin.

One really ugly workaround is to manually set the plugins via the commandline:

gconftool-2 --type l --list-type string --set /apps/compiz-1/general/screen0/options/active_plugins "[core,bailer,detection,composite,opengl,compiztoolbox,decor,move,vpswitch,place,mousepoll,resize,staticswitcher,imgpng,regex,gnomecompat,grid,snap,zoom,session,animation,workarounds,fade,cube,expo,scale,rotate,unityshell,unitymtgrabhandles]" && (unity &)

Running this will set the plugins to Unity's default, but will replace Wall with Desktop Cube and Rotate Cube.

Unity's default is to have 2x2 desktops, but for the cube you'll likely want 4x1 desktops. You can change this in the General Options plugin in the CompizConfig Settings Manager. Go to the Desktop Size tab, and change Horizontal Virtual Size to 4 and Vertical Virtual Size to 1.

enter image description here

You should now be able to rotate the cube using the default shortcuts:

Alt + Ctrl + and Alt + Ctrl +

share|improve this answer

that bug is fixed in unity 3.8.4. The Beta uses an earlier version of unity. so install the updates and test again. I tested it with my system. it doesn't yet work using compiz settings

share|improve this answer
    
Thanks for the reply. I've just tested it but run into the same problem, is there any way to get my normal taskbars etc back? I can't even use alt-f2 to run anything thanks again –  user12622 Apr 11 '11 at 21:53
    
@user12622 this should get your working setup back: askubuntu.com/questions/17610/… –  Jorge Castro Apr 11 '11 at 22:16

For 12.04 64 bit the following instructions worked well for me: http://opensource-sidh.blogspot.com/2011/06/enable-3d-cube-with-unity-in-ubuntu.html

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.