Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm getting started with Linux for the first time. I've installed 64 bit ubuntu desktop from the live CD.

There have been some issues with booting after installation. But i've managed to get ubuntu to start, allbeit with a 480 resolution.

I used the driver tool in settings to find the nvidia drivers and I've tried all 3 driver options that appear but after rebooting, I cannot startx. http://i1217.photobucket.com/albums/dd384/mctwist2/ubuntu/20130915_112758_zps45b3f699.jpg

I have tried the default nouveau drivers, but terminal tells me that I have broken packages.

Subsequently booted in recovery mode to fix any broken packages, which it appeared to do. But still wont successfully boot with the nvidia drivers:

http://i1217.photobucket.com/albums/dd384/mctwist2/ubuntu/20130915_113952_zpsd0971dce.jpg

I have also tried various nvidia driver installation methods using terminal, but these have returned the same problems. Both by going to the root in recovery mode and with cntrl+alt+f1 when at the login screen.

I don't think there's any way to change the resoultion from 480 4:3 without some kind of driver. I'm running an HP Pavilion with a Q8200 core2quad and Geforce GT 220 proprietary card.

Any recommendations?

Many thanks, Dan

share|improve this question

1 Answer 1

Dan, you don't say what version of Ubuntu you have installed.

I haven't run with nVidia drivers on Ubuntu for a couple of years now (though I'm itching to go back), but I did get the dreaded "no screens found" error on more than one occassion. It was usually because my /etc/X11/xorg.conf file was broken.

I've ratted through my backups to find this, from when I was running a Dell 2405FPW (wide screen), does your file look similar to the following?

Section "Monitor"
    Identifier     "Configured Monitor"
EndSection

Section "Screen"
    Identifier     "Default Screen"
    Device         "Configured Video Device"
    Monitor        "Configured Monitor"
    Option         "NoLogo" "True"
    DefaultDepth    24
    SubSection "Display"
        Depth       24
        Modes      "nvidia-auto-select"
    EndSubSection
EndSection

Section "Module"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "keyboard"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
    Identifier     "Default Layout"
    Screen         "Default Screen" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Device"
    Identifier     "Configured Video Device"
    Driver  "nvidia"
    Option  "NoLogo"    "True"
EndSection

If it looks ok then, as per the error message, /var/log/Xorg.0.log may contain some useful pointers.

Good luck!

share|improve this answer
    
Thanks Phoeey, the version of ubuntu i've installed is 12.04 (i think i mentioned this in the title). May i ask, how/where i can access this file? Thanks for your reply :) –  Dan_R Sep 15 '13 at 16:10
    
i've had a look around. I think that, by default, ubuntu 12.04 doesn't create xorg.conf.d files Please see configuration files from usr/share/x11/xorg.conf.d folder and Xorg.0.log file here: dropbox.com/sh/zj1ouz280oo0dms/mKNBFYMwJs –  Dan_R Sep 15 '13 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.