Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When trying to play youtube videos in Totem, I get this error:

GStreamer encountered a general supporting library error.

When starting from the commandline, the actual error is is this:

Message Error: GStreamer encountered a general supporting library error. gstffmpegdemux.c(1255):
gst_ffmpegdemux_open ():
/GstPlayBin2:play/GstURIDecodeBin:uridecodebin1/GstDecodeBin2:decodebin21/ffdemux_swf:ffdemux_swf1: "Input/output error"

There are several threads floating around other sites for this problem in 9.xx, but I'm on 10.10, and supposing the proposed updates are long propagated.

I have checked and the Gstreamer FFMPEG plugin is installed: everything is basically stock.

share|improve this question
1  
> The problem returns every time Google > changes its mind about the YouTube > API. (from here) :( –  törzsmókus May 8 '11 at 16:28
add comment

1 Answer 1

up vote 1 down vote accepted

As Törzsmókus pointed out, this is a known recurring bug. Totem's Youtube interoperation is achieved by reverse-engineering the Youtube API. So whenever Google changes the API, Totem breaks. The bug is marked fixed, but if it reappears, file a bug or comment on Launchpad.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.