Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu and love it so much, its so fast now. But i have a problem connecting to the internet.

I checked and saw i have to install the driver Broadcom STA wireless driver but every time i do try to install it it says:

Sorry, installation of this driver failed. Please have a look at the log files for details: /var/log/jockey.log

I went to terminal and copy and pasted the log file name. and when I did it said I have no permission to access this file. I checked on the forums that I have to be on a wired connection. So I plugged my laptop into my router and I got internet then tried to install the driver again. And it was loading then when it got to the end the same message popped up.

Also I have one of those little usb router things you plug into the computer and it gives you internet I have been using that but its to slow. So I want to use the one in my computer but cant. Ive been trying all day to get it to work please please help me. Also im runnung 12.04 Also i tried the command: sudo modprobe wl and when i type that command in it says: FATAL: Module wl not found

Since, I am so new at this all Ubuntu thing can u explain to me, how to fix this please?

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.