Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have seen this question asked by others but despite trying as many solutions as I can nothing seems to be working!

The closest I have come is using the answer to this question

Broadcom driver woes

which says i have connected to the wireless network, but it doesn't actually work.

I have an additional driver (the Broadcom STA wireless driver and from my play with the terminal its BCM 4312) but it will not activate.

What else can I try? And what other info would be helpful for you?

I am loving everything else about Linux and excited to use it on the wireless! Thanks for any help.

---Update---

The below path worked brilliantly - thank you so much!

share|improve this question
    
Possible duplicate of: askubuntu.com/questions/285463/… –  david6 Jan 25 at 0:36

3 Answers 3

Please do:

sudo apt-get purge bcmwl-kernel-source
sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer
sudo modprobe -r wl
sudo modprobe b43

now your wireless should be working.

share|improve this answer

JFYI, I'm using a Dell Latitude D620 with a broadcomm wireless driver. I'm testing out ubuntu 14.04 LTS for my first time today (I've tried other versions and still prefer backtrack 5 / ubuntu 10.04)

My wireless card was not activating by default, but I found this page and followed these instructions:

sudo apt-get purge bcmwl-kernel-source

sudo apt-get install b43-fwcutter firmware-b43-lpphy-installer

sudo modprobe -r wl

sudo modprobe b43

the third line was bugged, "wl" was not found. So I followed this link as described above:

https://launchpad.net/~eugenesan/+archive/ppa/+sourcepub/3331324/+listing-archive-extra (I chose the amd64 version) which launches ubuntu software center by default...

One trend I've noticed with Ubuntu Software Center is that often it installs 90% of a package and never "finishes" installing the package - and this is what happened again. Regardless, what has worked in the past is to close Ubuntu Software Center (which I did). The package was installed as far as I could tell, but in terminal, I tried "sudo modprobe -r wl" and got the response "wl is busy" so I restarted my pc. Lo and behold, after restart and third attempt at this line "sudo modprobe -r wl" my wifi indicator immediately lit up and it seems to be working fine. Thank you kindly for your help. I just wanted to let fellow linux users know that this worked for me, and also how I had to get it to work. Cheers!

PS I am running on 2gb of ddr2 ram, with a dual-core processor @ approx 1.85ghz... Which means I still prefer backtrack 5 / ubuntu 10.04 for my daily computing needs/desires. I feel ubuntu 12 and 14 (I did not try 13) are too bloated, and while there are some nice ideas I see coming to life, they do not to my knowledge follow the KISS method. Thanks anyways :) I will still give ubuntu 14 a shot on this machine. Much love ~

EDIT

I might keep ubuntu 14, due to the fact that I am unable to get flash player working in either chromium or firefox with backtrack 5 / ubuntu 10.04; if anyone out there has found a workaround, please send me a link @ beautiful.insanity.420@gmail.com... Thank you!

share|improve this answer

Can you please post the output of lspci -nn -d 14e4:

There is a bug in the wl module. Try downloading this patched package to see if that fixes the problem.

Here's a link to information on the b43 driver.

https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx

share|improve this answer
    
The result is... 0c:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01) –  user2772261 Sep 14 '13 at 23:05
    
Ok I edited my answer. –  linux_guest Sep 15 '13 at 2:25
    
If my answer helped, could you mark my response as "accepted"? –  linux_guest Sep 16 '13 at 2:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.