Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When opening a directory that is version controlled, especially one with subdirectories containing hundreds or thousands of individual files, Nautilus temporarily freezes (application does not respond to user input). A similar behavior applies to directories with hundreds or thousands of individual files. These freezes can last several minutes, during which CPU load barely climbs (2 - 4% above normal) but hard disk access is significant.

An example is a version controlled directory, with the complete Boost library source and GNU Science library source, both untarred, and the entire source tree of a hydrology model.

Is there a way to reduce or eliminate this problem? (Version control is critical and can't be altered; some file re-organization can be done for badly affected directories)

NOTE: This affects both 10.04 LTS (32-bit PAE) and 10.10 (64-bit). The lucid machine has a Core i7 (2.8GHz), 6GB RAM, and 1TB HDD with a 32MB cache. The maverick machine has a Core i5 (2.43GHz), 4GB RAM, and a 500GB HDD (unknown cache size). Both HDDs are 7200 RPM drives.

share|improve this question
1  
I don't have a solution, but it sounds like a typical blocking behaviour. If Nautilus issues the io-operations from the same thread that handles the user interface, the interface is deemed to freeze while it waits for the io operations to complete. –  Egil Apr 11 '11 at 19:36
    
@Egil So if it is a blocking IO op in the same thread, are there any commandline switches or configuration files that can affect that behavior? –  Tyler K. Apr 11 '11 at 19:48
    
You could try reducing the number of operations neccessary. See my answer below for a suggestion. –  Egil Apr 12 '11 at 8:28

1 Answer 1

One way to at least reduce the number of io operations is to disable (some of) the preview features in Nautilus. Open the Preview tab in File Management Preferences by clicking on Edit->Preferences. The previews works great for a limited amount of files, but it doesn't scale that well.

I reckon Count number of items: might be the culprit in your case, as it will go through all the directories with hundreds or thousands of files and count them all. Similarly, previewing text files will be heavy with thousands of them and so forth.

Nautilus Preview preferences

share|improve this answer
    
Disabling some or all of those features speeds up nautilus a lot, no matter what your setup is. When handling wordpress installations, "Count number of items" used to cause nautilus to freeze.. but I've never had this problem since I've upgraded my HDD. –  The Negative Shape May 12 '11 at 11:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.