Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

EDIT My computer is Thinkpad E420 with Intel HD3000 and ATI 6630m.

I have reinstalled my Ubuntu12.04.3 yesterday. I had successfully installed Ubuntu and ATI Catalyst Video driver many times about half year ago following these links:

How do I get AMD/Intel Hybrid Graphics drivers to work?

What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

However, this time I have no luck with installing ATI Catalyst Video driver. I have tried version 13.4, 13.1, 12.8 of ATI Catalyst Video driver.

It seemed that 13.4 doesn't support 12.04 any more, following this link , the lowest Ubuntu version supported by ATI 13.4 is 12.10 and for the reset of the ATI drivers, the kernel version and xorg version of Ubuntu 12.04.3 is too high to be supported.

So, should I stay on ubuntu 12.04.1 with ATI 12.8, or there is any way to install ATI driver on Ubuntu 12.04.3?

share|improve this question

closed as unclear what you're asking by Braiam, Ask, Eric Carvalho, BuZZ-dEE, Lucio Feb 14 at 16:28

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question.If this question can be reworded to fit the rules in the help center, please edit the question.

    
What video card are you using? –  PeppeDAlterio Sep 14 '13 at 17:01
    
@PeppeDAlterio Intel HD3000 and ATI 6630M –  Eastsun Sep 14 '13 at 17:05
    
I presume they fixed this, is this still reproducible. –  Braiam Feb 12 at 1:03

3 Answers 3

Not sure if I'm late in helping to answer the question. Actually this problem has existed since version 12.11 version of AMD Catalyst Drivers for Ubuntu 12.04 Users. Please refer to this Bug Tracker thread (which I have participated in when I experienced the same problem): http://ati.cchtml.com/show_bug.cgi?id=679.

Here is the explanation, as indicated in one of the comments of that thread:

It is clearly looking for the files in the wrong directory.

I suspect the workaround is to dump the source, fix the broken script, and create the proper packages.

Basically, the driver works properly; it's just the installer itself that has the problem/bug, that is why when you run the command "sudo sh *.run --buildpkg Ubuntu/precise" as per the tutorials in this thread: What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

...it gives you an error.

So, the solution is to manually "unpack" the AMD installer package. Comment #3 of the referenced thread gives the commands for it.

I have tried the procedure both on versions 13.1 and 13.4 of the AMD Catalyst drivers, with success.

EDIT: by request of a fellow member, I am copy-pasting the steps which I have posted in the link I have provided.

The procedure involves three (3) commands that you will just copy-paste in the Terminal. Make sure that in Terminal, you are in the directory where the AMD Catalyst installer is located. It is recommended to save the installer in a folder.

Step 1: this command will extract the contents of the installer into a folder named "amd". The step below is when I was using AMD Catalyst version 13.1. It also worked with version 13.4; just change the command accordingly to conform to the version you are working on.

bash amd-driver-installer-catalyst-13.1-linux-x86.x86_64.run --extract amd

Step 2: this will find the Ubuntu "Precise" version of the driver. You can modify to your respective Ubuntu version (so, if I'm on Ubuntu 12.04, it will be "find amd/package/Ubuntu/dists/precise/rules...etc. etc.)

find amd/packages/Ubuntu/dists/precise/rules -type f -exec sed 's/\("arch\/\)x86_64\(\/usr\/share\/ati\/lib"\)/\1x86\2/' -i {} \;

Step 3: This creates the packages for use with Ubuntu Precise Pangolin.

bash amd/ati-installer.sh -- --buildpkg Ubuntu/precise

From here, you now have .DEB files of the AMD Catalyst driver and hence, you can already install them via "sudo dpkg -i *.deb" command (make sure that in Terminal, you are in the folder where the extracted files are located).

share|improve this answer

Ubuntu 12.04.3 uses kernel 3.8 which is supported by catalyst 13.4 (Linux kernel 2.6 or above (up to 3.8)).

You can manually install the upstream driver following this guide: https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Installing_upstream_drivers_directly_from_AMD.27s_website

First remember to uninstall the older version of driver from your system! You can do this by running this script:

sudo sh /usr/share/ati/fglrx-uninstall.sh

removing these packages:

sudo apt-get purge fglrx*

and removing your xorg.conf:

sudo rm /etc/X11/xorg.conf

then reboot your system.

Remember to install these dependencies packages before you begin installing the driver:

sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases

64bit only:

sudo apt-get install ia32-libs-multiarch i386 lib32gcc1 libc6-i386

PS: Don't forget to sudo aticonfig --initial when installation is complete, before rebooting.

share|improve this answer
    
Sadly, this doesn't work. The system is running in low-graphics mode when after reboot. –  Eastsun Sep 14 '13 at 18:44
    
Have you followed the point for Intel/AMD hybrid graphics of the guide? –  PeppeDAlterio Sep 14 '13 at 18:55
    
I have tried the two methods one by one, but all failed. –  Eastsun Sep 14 '13 at 19:04
    
Very strange... anyway you can uninstall fglrx to "fix" the fallback problem and, if you want (or need the proprietary driver), try to install the 13.8beta driver. –  PeppeDAlterio Sep 14 '13 at 19:12
    
it seems that the 13.1 driver is the last one supporting ubuntu 12.04, so I doubt if 13.8 support ubuntu 12.04 –  Eastsun Sep 14 '13 at 19:19

On my T400 laptop, the ATI mobility radeon graphics card has become unsupported by the latest 13.10 fglrx driver.

(II) Module fglrx: vendor="FireGL - AMD Technologies Inc."
   compiled for 1.4.99.906, module version = 13.10.10

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV620/M82 [Mobility Radeon HD 3450/3470]
$ lspci -n | grep 01:00.0
01:00.0 0300: 1002:95c4

The /var/log/Xorg.0.log shows this line:

(EE) No supported AMD display adapters were found

Fixed by downgrading and locking the fglrx package with synaptic manager: http://www.howtogeek.com/117929/how-to-downgrade-packages-on-ubuntu/

As text:

  1. start synaptic
  2. search for the fglrx package
  3. choose menu Package -> force version
  4. after selecting the earlier version, click apply
  5. choose menu Package -> lock version

Now Steam on Linux works again too.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.