Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I always have high CPU usage in Ubuntu in every version of it that I have used. I have been using Ubuntu from 10.04 version.

My CPU usage even at idle is more than 30% for each core(unlike Windows 7 uses only 5%) due to which i'm getting my processor under very high temperature. Even my friends too experienced the same problem. This is not solved even now in 13.04. I'm not telling this just by installing Ubuntu in only my system, but I have tested it with single core and multi core processors with and without graphics cards, everything type of configuration gave me the same results.

Someone please help me how to solve this problem, as i'm experiencing this for years.

Currently my system configuration is,

  • AMD Phenom x6 1100t processor
  • AMD Radeon HD 6770 GDDR5 graphics
  • 4GB ram
  • 1TB hdd
share|improve this question
    
What does the System Monitor say? Are there any out of control processes eating up resources? –  Richard Sep 14 '13 at 12:43
add comment

2 Answers

Despite you not having a program open on the desktop there are still scores of processes running on your computer. On Windows you'd use the Task Manager to see which processes are running. On Ubuntu you use the System Monitor (Applications, System Tools, System Monitor). Click on the % CPU column to order by CPU hogs first and you'll soon see which processes are at fault.

Likely candidates:

  1. gnome-system-monitor itself because, well, you're running it and it's doing stuff.

  2. tracker-miner-fs, which is the file indexing service. Go to Applications, System Tools, Preferences, Search and Indexing and select "Only when computer is being used." There's no "off" switch, unfortunately, but you can achieve the same result by moving the "Stop indexing when disk space is below" slider to some really high value.

  3. compiz, which is the desktop compositor. Try going to Applications, System Tools, Preferences, CompizConfig Settings Manager and turning off all of the (probably unnecessary) eye candy.

Even with all your CPU cores pegged at 30% your CPU should not be getting overly hot. Consider clearing any dust from its heat sink and/or upgrading to a better one.

share|improve this answer
    
Thank you for your reply, but there is no such process like that , and 30% is at startup only , after few minutes it reaches 50% and beyond which makes me nervous. Is there any bug in system monitor tool or in OS itself. –  Mukesh Sep 16 '13 at 15:30
add comment

You first should figure out what process is eating away your CPU.

  • open a terminal with ctrl+alt+t
  • execute the command top
  • note the process using the most cpu

If the process isn't a system process, kill it with sudo pkill [processname] with [processname] the name of the process you want to kill. If it is a system process, don't kill it, but try to google the name and figure out what functionality it has in Ubuntu. Then you can proceed to turn it of (in e.g. you system settings).

share|improve this answer
    
thank you for your reply dude :). it helped me to monitor all the process but didn't solved the problem :( –  Mukesh Sep 16 '13 at 15:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.