Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So yesterday I installed Ubuntu on my new laptop and the Enable Wifi option was greyed out. I searched for a solution via my PC and the only thing I could find was the command rfkill unblock all. Tried it, but it didnt work. Tried a lot of combinations with block and unblock certain devices, but none worked. So I just got fed up with it and stuck the ethernet cable in the laptop and all of a sudden, Enable Wifi was not greyed out anymore and I didn't have to use the ethernet cable. Downloaded and installed the updates after that and restarted and when Ubuntu loaded, the Enable Wifi option was greyed out again. Oh yeah, it says that hardware switch is blocking the Wifi from connecting but there is no physical switch and the Fn+F2(wireless) is enabled. So, please, HELP!!!

share|improve this question
    
icepick19 - you appear to have multiple accounts. Please register one of these accounts and then click the contact-us link at the bottom of this page to request that your other accounts are merged. Once done, you'll be able to edit and reply to answers. Thanks. –  fossfreedom Sep 14 '13 at 10:48

1 Answer 1

Try this:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.