Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, so I'm kind of new to linux, but I know computers very well so I can take commands.

My problem is when I tried to expand my extended partition that houses my ubuntu partition I get an error saying "Unable to satisfy all constrains on the partition"

It is important that I get the problem fixed ASAP. I don't know what exactly you need to know to fix my problem, but here are a few things and don't be afraid to ask for more of what you need.

Tried to partition with GParted in an Ubuntu Live USB (Ubuntu Live 13.04 x64).

My partition map looks like this:

Partition:                                 Size:

/dev/sda1 | TOSHIBA System Volume | 1.46 GiB

/dev/sda2 | Windows 7 | 104.08 GiB

unallocated | The space I want to add | 99.21 GiB

ᐁ /dev/sda3 | The extended partition | 81.06 GiB

      /dev/sda5 | My ubuntu partition | 81.06 GiB

unallocated | extra space added in ubuntu installation | 2.00 MiB

/dev/sda4 | HDDRECOVERY | 12.27 GiB

OUTPUT FROM sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xcd9fd9b7

   Device | Boot | Start | End | Blocks | Id | System

/dev/sda1 | * | 2048 | 3074047 | 1536000 | 27 | Hidden NTFS WinRE

/dev/sda2 | | 9893888 | 221351935 | 105729024 | 7 | HPFS/NTFS/exFAT

/dev/sda3 | | 429400062 | 599398399 | 84999169 | f | W95 Ext'd (LBA)

/dev/sda4 | | 599402496 | 625141759 | 12869632 | 17 | Hidden HPFS/NTFS

/dev/sda5 | | 429400064 | 599398399 | 84999168 | 83 | Linux

Disk /dev/sdb: 32.0 GB, 32015679488 bytes

255 heads, 63 sectors/track, 3892 cylinders, total 62530624 sectors

Units = sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 512 bytes

I/O size (minimum/optimal): 512 bytes / 512 bytes

Disk identifier: 0x00093c4b

   Device | Boot | Start | End | Blocks | Id | System

/dev/sdb1 | * | 32 | 62527487 | 31263728 | c | W95 FAT32 (LBA)

THE ERROR I AM GETTING IN GPARTED

GParted 0.12.1 --enable-libparted-dmraid

Libparted 2.3
Move /dev/sda3 to the left and grow it from 81.06 GiB to 82.20 GiB  00:00:02    ( ERROR )

calibrate /dev/sda3  00:00:02    ( SUCCESS )

path: /dev/sda3

start: 429,400,062

end: 599,398,399

size: 169,998,338 (81.06 GiB)

move partition to the left and grow it from 81.06 GiB to 82.20 GiB  00:00:00    ( ERROR )

old start: 429,400,062

old end: 599,398,399

old size: 169,998,338 (81.06 GiB)

requested start: 427,008,000

requested end: 599,396,351

requested size: 172,388,352 (82.20 GiB)

libparted messages    ( INFO )

Unable to satisfy all constraints on the partition.

========================================

Again if there is any other info you need just ask, it is important that I can fix the problem. I am working on making my own Linux distro to learn more about Linux, and who doesn't want their own OS? I mean come on. I will try with the windows partition manager but I expect no better.

Thank you!

share|improve this question

closed as off-topic by psusi, Braiam, Alaa Ali, guntbert, Caesium Sep 19 '13 at 18:51

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – psusi, Braiam, Alaa Ali, guntbert, Caesium
If this question can be reworded to fit the rules in the help center, please edit the question.

    
post your gparted screenshot here –  Aaditya Bagga Sep 14 '13 at 6:58
    
Please file a bug: bugs.launchpad.net/ubuntu/+source/gparted/+filebug –  psusi Sep 15 '13 at 1:47

3 Answers 3

up vote 0 down vote accepted

When I come across this error, I try again, but make sure that that the option "Align to" is set to "none" (it seems to use MiB by default). This usually works for me, although sometimes I have to try it two or three times before it works. This might not be the best solution, but it might work for you.

share|improve this answer

Many partition constraint problems have been fixed in GParted since version 0.12.1 was released. You might try using the latest version of GParted (currently 0.16.1). One way to do this is to boot from media containing GParted Live.

If that does not help, then the problem might be that logical partition sda5 starts just 2 sectors after the start of extended partition sda3. After ensuring you have a good backup of your data, you might try shrinking sda5 by 1 MB from the left edge. When this is successful you could try resizing the extended partition sda3.

share|improve this answer

This seems to have worked for some people

Somehow "unable to satisfy all constraints on the partition" problem disappeared after a left 1Mb of free space before the first partition

also

When the extended partition got a little bit of space at the start, I could grow it to the right and carry on with what I was trying to do.

Links-

http://ubuntuforums.org/showthread.php?t=1478324&page=2

http://gparted-forum.surf4.info/viewtopic.php?id=14448

Edit-

Read more on this topic, and it could be a partition table issue also. You would need to fix the partition tables.

You can do this with Fixparts, http://www.rodsbooks.com/fixparts/, read about it thouroughly, and use it with caution, according to the steps given on its website.

See also this link-

Fix - unable to satisfy all constraints on the partition

share|improve this answer
    
Ok, well thanks for the help, but it did not work so I guess I'm stuck with a small partition that I can not use for now. :/ Any other tips or ideas would be great –  Dalton Sep 14 '13 at 20:57
    
Are you using RAID? In that case this could help perhaps askubuntu.com/questions/316610/… –  Aaditya Bagga Sep 15 '13 at 4:28
    
You could also use this tool "Fixparts" rodsbooks.com/fixparts –  Aaditya Bagga Sep 15 '13 at 4:33
    
See this too gparted.sourceforge.net/h2-fix-msdos-pt.php it says that the error could occur if the partition table wasnt correct, in which case it could be fixed by Fixparts –  Aaditya Bagga Sep 15 '13 at 4:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.