Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install ia32-libs-multiarch but I get the following error. What am I doing wrong?

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help resolve the situation:

The following packages have unmet dependencies:
 ia32-libs-multiarch:i386 : Depends: gstreamer0.10-plugins-good:i386 but it is not going to be installed
                            Depends: gtk2-engines:i386 but it is not going to be installed
                            Depends: gtk2-engines-murrine:i386 but it is not going to be installed
                            Depends: gtk2-engines-pixbuf:i386 but it is not going to be installed
                            Depends: ibus-gtk:i386 but it is not going to be installed
                            Depends: libaudio2:i386 but it is not going to be installed
                            Depends: libcanberra-gtk-module:i386 but it is not going to be installed
                            Depends: libcups2:i386 but it is not going to be installed
                            Depends: libcupsimage2:i386 but it is not going to be installed
                            Depends: libgail-common:i386 but it is not going to be installed
                            Depends: libgtk2.0-0:i386 but it is not going to be installed
                            Depends: libqt4-opengl:i386 but it is not going to be installed
                            Depends: libqt4-qt3support:i386 but it is not going to be installed
                            Depends: libqt4-scripttools:i386 but it is not going to be installed
                            Depends: libqt4-svg:i386 but it is not going to be installed
                            Depends: libqtgui4:i386 but it is not going to be installed
                            Depends: libqtwebkit4:i386 but it is not going to be installed
                            Depends: libxaw7:i386 but it is not going to be installed
                            Depends: xaw3dg:i386 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
possible duplicate of How do I resolve unmet dependencies? –  Eliah Kagan Sep 13 '13 at 23:08
    
This isn't a dupe. The problem is more specific and has unique aspects that aren't present in the generic "unmet dependencies" issue. –  user3875 Sep 13 '13 at 23:59
    
I managed to solve my root problem (getting Android SDK to run) by installing libc6-i386 libstdc++6:i386 –  user3875 Sep 14 '13 at 1:01
    
Could you post that as answer? –  Braiam Sep 14 '13 at 1:28
    
I could but it's the answer to a different question. I could change the question but I think it still has value as is. I'm surely not the only one who was unable to install the package. –  user3875 Sep 14 '13 at 1:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.