Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I see that this problem has come up several times but none of the solutions have worked for me. I've tried the rfkill unblock all method. I've tried finding additional drivers but none come up. I have an Asus U56E and my wireless card is Intel N 6150

rfkill list all
0: i2400m-usb:1-1.1:1.0: WiMAX
    Soft blocked: yes
    Hard blocked: no
1: asus-wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: no
2: asus-wimax: WiMAX
    Soft blocked: no
    Hard blocked: no
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

david@david-U56E:~$ lspci | grep -i wireless
02:00.0 Network controller: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)
share|improve this question

Firmware for Intel wireless drivers (`iwlwifi) should be already packaged in the repos.

sudo apt-get install firmware-iwlwifi

should do it. You may need a reboot for installation to take effect.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.