Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How can I disable cryptswap? I would like an unencrypted swap like before.

This is on an ubuntu 9.10 system.

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

I followed this explanation (currently down, see its google cache), and it worked without any problems.

share|improve this answer
add comment

If you used cryptsetup to create your encrypted swap, you can easily reverse the process:

Currently your /dev/hda? will be mapped to cryptswap (something like cryptsetup luksOpen /dev/hda4 cryptswap)

so first disable the line in /etc/crypttab that mentions cryptswap and remove the cryptswap line from /etc/fstab

Then use cryptsetup to remove the crypt mapping.

At this point you can remove the swap partition and recreate it as an ordinary partition

share|improve this answer
add comment

To remove crypt mapping use something like this:

cryptsetup remove cryptswap1

Or just reboot the computer. If you remove/comment lines from /etc/crypttab and /etc/fstab, encrypted swap will not created on the next boot.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.