Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04.3 on a Windows 7 machine. I selected to install it with Windows 7 as a dual boot. Ubuntu installed correctly but when I boot the machine it always boots Ubuntu so I do not get the option to select Windows. How do I fix this?

share|improve this question
add comment

2 Answers

I hope you didn't select to install Ubuntu only, instead of alongside accidentally. You could check if there is an existing ntfs partition using the file manager or gparted to check if both OS's are installed.

Other than that I would recommend to use boot-repair, which is a tool to repair the boot. It pretty much reinstalls grub, the boot-loader which lets you select the OS at each startup. see: https://help.ubuntu.com/community/Boot-Repair

share|improve this answer
    
The Windows partitions are still there it is just that I never get the option to select Windows. I will try the boot repair –  Dave Sep 13 '13 at 15:54
    
to clarify, are your receiving a message to select Ubuntu before Ubuntu starts or does it just go into Ubuntu directly without a menu with Ubuntu and other choices? (i.e. memtest or save boot) –  Maebbie Sep 13 '13 at 15:59
    
I just goes direct to Ubuntu without a menu –  Dave Sep 13 '13 at 16:01
add comment

I don't have any direct solution to your problem but thought I might share the process the way I dual boot.

  1. Install Win 7 first. In the advance partitioning option I prepare two drive (/ and swap) ahead.

  2. Install using a live disk. Ubuntu never missed to detect my win 7 installation.

share|improve this answer
1  
Did you run sudo update-grub? –  oldfred Sep 13 '13 at 15:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.