Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Steam was running fine for a few months, but recently it didn't start up, so I tried re-installing it and it still doesn't start!

Is it My PID and how do I check if My PID is running?

share|improve this question
add comment

marked as duplicate by Andrea Corbellini, guntbert, Alaa, Eric Carvalho, Eliah Kagan Sep 14 '13 at 5:13

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer

I just had a very similar problem with my steam. What i did to fix my problem was to go to System Monitor. And in the processes tab i found steam and ended the process. Then i restarted my steam and everything worked fine.

I have no idea if this will work for you, but i hope it helps.

GL

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.