Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My hard disc or pendrive is detected by Ubuntu but it is not showing on my screen.

In terminal, I just typed dmesg after inserting my hard disc into and it is showing very verbose thing in which it is mentioning my external hard disc and its memory as well.

I guess it detects my external device but it is not appearing.

Can I access my external device on screen by any possible way?

I am using Ubuntu 12.04 64-bit.

I ran the command

sudo fdisk -l

and it is giving me the output: omitting empty partition (5)

Disk /dev/sda: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x309fd85a

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      718847      358400    7  HPFS/NTFS/exFAT
/dev/sda2          718848   210434047   104857600    7  HPFS/NTFS/exFAT
/dev/sda3       210436094   936773631   363168769    f  W95 Ext'd (LBA)
/dev/sda4       936773632   976769023    19997696    7  HPFS/NTFS/exFAT
/dev/sda5       294324224   615548927   160612352    7  HPFS/NTFS/exFAT
/dev/sda6       615550976   721735679    53092352    7  HPFS/NTFS/exFAT
/dev/sda7       721737728   936773631   107517952    7  HPFS/NTFS/exFAT

Disk /dev/sdc: 7818 MB, 7818182656 bytes
76 heads, 12 sectors/track, 16743 cylinders, total 15269888 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc3072e18

   Device Boot      Start         End      Blocks   Id  System
/dev/sdc1            8064    15269887     7630912    b  W95 FAT32

Disk /dev/sdd: 500.1 GB, 500107862016 bytes
255 heads, 63 sectors/track, 60801 cylinders, total 976773168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf7ad36ed

   Device Boot      Start         End      Blocks   Id  System
/dev/sdd1   *          64   976768064   488384000+   7  HPFS/NTFS/exFAT

what should I do?

EDIT:

I had tried what @Alaa mentioned in his answer, but I am still not able to get the complete solution. I typed the commands and added the same two lines then finally I got :

naveenk@ubuntu:~$ sudo mount -a

"Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command. Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command."

But when I added the two lines with replacing sdc with sda I got:

naveenk@ubuntu:~$ sudo mount -a

Mount is denied because the NTFS volume is already exclusively opened. The volume may be already mounted, or another software may use it which could be identified for example by the help of the 'fuser' command.

I had tried sdc by sda as my Disc drive was detected in sda as I ran the commands suggested by krowe.

I am a beginner in Ubuntu so I am not able to fix it anyway.

share|improve this question
1  
I rejected your edit to Alaa's answer because edits should be used to improve answers only, not start a discussion. Please edit your problems into your question and then comment under Alaa's answer. (It looks like he already did the editing for you :) –  Seth Sep 13 '13 at 19:24
    
@user192632 do not change sdc to sda. Each device you plug into Ubuntu gets a name. Your internal hard disk is sda. Your pendrive (sdc) is an 8 GB pendrive, and your external hard drive (sdd) is a 500 GB one, right? I have edited my answer below; please do step 1, the umount command, then you can skip all the steps (since you've already done them) and just do step 8, sudo mount -a and see what happens. You should not get errors. –  Alaa Ali Sep 13 '13 at 22:20

2 Answers 2

They might not be automatically mounting because there's a setting that needs to be done. First, unplug your external hard drive/USB stick, then type the following in a terminal:

gsettings set org.gnome.desktop.media-handling automount true
gsettings set org.gnome.desktop.media-handling automount-open true

Now, plug the device back in and see if it automounts. If it does, then that's it.

If it doesn't, then follow the below:

  1. sudo umount /dev/sdc1 && sudo umount /dev/sdd1.

    • This will unmount your pendrive and external hard drive first.
  2. sudo mkdir /media/externalHDD /media/pendrive

    • This creates the mount points for your external disk and pendrive. You can change the names to anything you want.
  3. sudo cp /etc/fstab /etc/fstab.bak1

    • This will backup the file that we're going to edit now.
  4. sudo nano /etc/fstab

    • This will open up the fstab file for us to edit.
  5. Add the following two lines to the end of the file (you can paste in the terminal by Ctrl+Shift+V):

    /dev/sdc1   /media/pendrive       auto    defaults,umask=003   0    0
    /dev/sdd1   /media/externalHDD    auto    defaults,umask=003   0    0
    
  6. Save and close the file by Ctrl+X, then Y, then Enter.

  7. sudo mount -a

Your drives should magically be accessible.


If the drives are not appearing on the desktop, try executing the following command:

gsettings get org.gnome.nautilus.desktop volumes-visible

And see if they appear.

share|improve this answer
    
Thank you Alaa .. now I got the solution .I am able to get my pendrive in media file but I am not getting 'eject' option to eject my pendrive.Can I also get the way by which I could get pendrive visible on Desktop and easy to read/eject it when required ? –  user192632 Sep 14 '13 at 8:11
    
I edited my answer; check the last part and see if it works. However, for ejecting (and easily mounting), you should see an icon in the Launcher than you can right click and choose to "Eject" or "Safely Remove" (like this: i.imgur.com/CLnPKnU.png). –  Alaa Ali Sep 14 '13 at 8:22
    
I used this command and it did not show any error in terminal but still I am not getting anything on Desktop!!!! –  user192632 Sep 14 '13 at 8:48
    
the output on terminal is 'true'. –  user192632 Sep 14 '13 at 8:55

At the command prompt type:

# lsusb

This will display all of your USB devices. If your output doesn't list anything that looks like your flash drive, I recommend trying different USB ports on your computer to see if it can get listed. You must get your computer to recognize your flash drive in order to continue.

Then make a directory anywhere:

# mkdir ~/flash

Assuming that the drive you want is the one at sdc then all you need to do now is mount it:

# mount -t vfat -o uid=yourUserNameHere,gid=users /dev/sdc ~/flash

If sdc isn't the drive you want to mount then you may look for it in your dmesg logs:

# dmesg | grep -i "sda"

Check sda, sdb, sdc, ... until you find something that looks like the drive you want.

When you are done issue an umount command:

# umount /dev/sdc
share|improve this answer
    
Hi krowe, I got disc in sda but when I am typing:#umount /dev/sda the output is:umount: /dev/sda is not mounted (according to mtab) ! –  user192632 Sep 13 '13 at 17:02
    
Sorry for the confusion but umount is meant to be ran when you are ready to remove your drive. Still, if you ran the other commands correctly, it should've quit without the message. When you ran mount did you remember to replace /dev/sdc with /dev/sda? Also, did you change the uid part to use your actual user name? BTW, /etc/mtab is a listing of currently mounted devices and /etc/fstab is the listing of known mountable devices which you create. Once you figure out how to mount this we can make this easier in the future by utilizing fstab. –  krowe Sep 13 '13 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.