Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been having this problem this whole day and it's been killing me... I'm following Dual boot Surface Pro with Ubuntu? this guide to dual boot my Microsoft Surface Pro with Ubuntu 13.04.

The main problem I have is that the WiFi doesn't work and I do not have a Ethernet port on this device. I get to the point in the guide where he installs boot-repair, the problem is that he downloads it off the internet... which I have no access too.

Just so you know, I am have Ubuntu on my device installed under a partition. I did the try and install Ubuntu option, installed it and now I'm "continuing testing", simply just trying to get Grub2 to work, so I can switch between partitions. WiFi would be a plus too, but that shouldn't be difficult once I get this out of the way.

So I've tried a few things... I downloaded the tar.gz of boot-repair on my other partition and grabbed it from there. There is absolutely no documentation that tells me how to manually compile it, so I got stuck there.

I tried to do step 7 on the tutorial, download the two .deb files and get them on to this OS from my Windows partition and manually install them using the "sudo dpkg -i package.deb" command. The .deb's installed by my internet still isn't working. Even when I double click them so I can use the Ubuntu Software Center, the install button is just grayed out.

I tried using EasyBCD on my Window partition to set up a way to access my Ubuntu Partition from boot up but I just get a WBM error and then Windows 8 boots after. I just want to get Grub2 working so I can actually tackle this WiFi issue without constantly having to boot off this annoying flash drive. Is there anyone I can get Grub2 or any way to switch between partitions working without WiFi?

I appreciate all the help, after a few beers and about 8 hours of working on this straight I'm about to throw my Surface out the window. Cheers.

share|improve this question
    
I can try to help you compile the tar.gz if you're still working on this problem –  Freedom_Ben Sep 26 '13 at 16:22
    
First off, I don't own a Surface Pro; I am in the process of buying one for my daughter. What is holding me back is the fact that I have yet to read from someone who has successfully dual booted it with Ubuntu Linux. While my laptop dual boots Win 7 Pro full and Ubuntu Linux 13.04 (both 64 bit), I bumped into the same issue you described. The way I solved the problem was through the use of wired (Ethernet) lan. Have you considered using a (micro)-USB-to-ethernet adapter? Experience has taught me that there are times the only way to get Ubuntu working properly is to get a physical connection up –  user222952 Dec 7 '13 at 0:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.