Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an external hard drive with the following partitions. I am running Ubuntu 13.04 (Raring Ringtail) on the same ext. hard drive and am unable to mount the NTFS partition on this drive. Could someone help please?

Here's the output of the fdisk -l command:

Disk /dev/sdf: 1000.2 GB, 1000204885504 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525167 sectors
Units = sectors of 1 * 512 = 512 bytes                              
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002e048

   Device Boot      Start         End      Blocks   Id  System
/dev/sdf1   *        2046   716802047   358400001    5  Extended
/dev/sdf2       716802048  1953519615   618358784    7  HPFS/NTFS/exFAT
/dev/sdf5            2048   708788223   354393088   83  Linux
/dev/sdf6       708790272   716802047     4005888   82  Linux swap / Solaris

I have tried mounting it using the mount command with admin privileges as listed here: https://help.ubuntu.com/community/Mount/USB. The output is listed below:

Command: mount -t ntfs-3g /dev/sdf2 /media/disk1/ Output:

NTFS signature is missing.
Failed to mount '/dev/sdf2': Invalid argument
The device '/dev/sdf2' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?

However on Windows 7 the NTFS partition of this drive mounts perfectly well.

share|improve this question
    
Does it appear in left side of File Manager, where other disk drive and places appear? If not try to mount it with gparted or Disk Utility. May be gparted would not be installed, so install it by sudo apt-get install gparted –  Saurav Kumar Sep 13 '13 at 10:04
    
It shows up in the left sidebar of File Manager but it's not mounted there it's just listed. I tried to mount the drive using gparted as well, but the Mount option is not active for this partition. There's a warning as well which says: Unable to read the contents of this file system! Because of this some operations may be unavailable. –  Harsh Purwar Sep 13 '13 at 11:43
1  
If Windows mounts it ok, just try running chkdsk from Windows on that partition. That also updates Partition boot sector which is where NTFS signature is seen from Linux. –  oldfred Sep 13 '13 at 16:20
add comment

1 Answer 1

up vote 0 down vote accepted

It seems that the partition I was trying to mount wasn't a NTFS partition after all, instead it was an exFAT (Extended FAT) partition that I created and forgot during the installation of Ubuntu on my drive. So I copied all my data from this so called "NTFS" partition to another drive and reformatted the partition as NTFS using Windows. And now it works fine with Ubuntu as well.

I am sorry for wasting all you guys' time. And also wanna thank you all for trying to help me out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.