Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have recently bought a new Acer V3-772G laptop and now I'm trying to install Ubuntu using a flash drive. This laptop has UEFI, but it can be disabled by switching to Legacy mode. I have done it to allow booting from a flash drive and when I boot it up, I can hear the Ubuntu welcome sound, but I can see nothing on the screen. It's not even purple or black, it looks like it is completely turned off.

Possibly it has something to do with one of the following:

  • the laptop has the NVIDIA Optimus system with Intel 4600 and GeForce 760M adapters
  • the flash drive has been created by Unetbootin instead of Ubuntu's native flash drive creation tool
  • perhaps the UEFI legacy mode interferes with the boot process

I'm not sure what to do and how do I even start to diagnose what happens. Any help would be greatly appreciated!

share|improve this question
    
I'm afraid I don't have any advice, but I can confirm that on some notebooks with two graphics chips the screen stays switched off, if both graphics chips are enabled simultaneously. If you would find a way to temporary disable one of them, you might therefore get the display working. A thing that you might try is to set the nomodeset kernel parameter (-> this gives text mode consoles) and boot without splash and quiet options to further diagnose your issue. askubuntu.com/questions/38780/… –  soulsource Sep 13 '13 at 10:43
    
@soulsource Can you post that in an answer? The nomodeset actually did the trick. –  Igor Zinov'yev Sep 13 '13 at 12:02

1 Answer 1

up vote 1 down vote accepted

This can have many reasons. For instance some laptops with two graphics chips switch off their monitor if both graphics chips are enabled simultaneously. If this is the case with your laptop, you should find a way to disable one of the graphics chips.

On some other laptops it helps to disable Kernel mode setting (mode setting is done by x.org in that case). If you are lucky, X.org detects the supported modes of the laptop screen correctly and your system simply works with KMS disabled. There is an answered question on how to disable KMS already. Also, if this works up to the point where X.org starts, maybe the supported resolutions are detected incorrectly. To fix this, you can try to boot to recovery mode and install proprietary GPU driers (those seem to detect the appropriate values more reliably) or to add modelines to xorg.conf.

In addition, you can try to disable the spash screen, or to display the boot process status messages (to get more information on what is going wrong). To do this, proceed just as with KMS, but remove the "quiet" and "splash" parameters.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.