Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having trouble with apt-get. When I try to install something, it tells me, that some packages has unmet dependencies, and I should run apt-get -f install to correct them. When I do so, I get the following error

tux@netbook:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libqt4-network
The following packages will be upgraded:
  libqt4-network
1 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
39 not fully installed or removed.
Need to get 0 B/551 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
dpkg: error: parsing file '/var/lib/dpkg/status' near line 37020 package 'apparmor':
 field name `"/etc/apparmor.d/abstractions/ubuntu-xterm' must be followed by colon
E: Sub-process /usr/bin/dpkg returned an error code (2)

In the last line, it says sth with dpkg: error: parsing file....

I can do a sudo apt-get update, sudo apt-get clean and sudo apt-get autoclean which works, but doesn't solve the error above.

I also tried the answer from dpkg: error: parsing file '/var/lib/dpkg/available' near line 0 sudo dpkg --clear-avail, sudo apt-get update which works, but doesn't solve the problem either.

I googled around, but couldn't find a solution. Something with the libqt4-network packages seems to be wrong, but how could I fix this? I also tried clean and autoclean, but none of them worked.

share|improve this question
    
highly duplicated askubuntu.com/questions/55099/… –  Braiam Sep 15 '13 at 3:06
    
Unfortunately that didn't solved my problem. I get still the same error –  23tux Sep 16 '13 at 1:18
    
What error? What you tried? Could you edit your question and add those details. –  Braiam Sep 16 '13 at 1:19
    
I updated the question. Hope you can give me some hints how to solve this. Thx! –  23tux Sep 17 '13 at 23:53
    
If you do sudo mv /var/lib/dpkg/status /var/lib/dpkg/status.bk && sudo mv /var/lib/dpkg/status-old /var/lib/dpkg/status, then try the operation again, do it fix the problems? –  Braiam Sep 17 '13 at 23:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.