Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have Ubuntu 12.10 x64 running in a VM in VirtualBox. I was writing some code, and then I minimized the VM window for a few seconds. I tried to open it back up, and it crashed (or had crashed sometime when it was minimized). When I restarted, X was no longer starting, but I was able to log in to terminal and access my file system.

I did just change my screen configuration today (from Gnome's "Displays" configuration window) to 2 screens instead of 1. It was working just fine for hours and then this happened.

Anyway, this is what I see with dmesg:

[   32.168521] Console: switching to colour frame buffer device 80x30
[   32.168532] fb0: VESA VGA frame buffer device
...
[   35.114612] init: lightdm main process (1014) terminated with status 1
[   50.270170] init: failsafe-x main process (1347) terminated with status 1

startx gives me this:

[   487.758] (==) No Layout section.  Using the first Screen section.
[   487.758] (==) No screen section available. Using defaults.
[   487.758] (**) |-->Screen "Default Screen Section" (0)
[   487.758] (**) |   |-->Monitor "<default monitor>"
[   487.758] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
...
[   487.778] (EE) Screen(s) found, but none have a usable configuration.
[   487.778] 
Fatal server error:
[   487.778] no screens found
[   487.778] (EE)
...

sudo Xorg -configure gives me this:

(++) Using config file: "/home/xxx/xorg.conf.new"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Number of created screens does not match number of detected devices.
  Configuration failed.

After checking the xorg.conf.new file, it shows 3 screens and 3 devices. I only have 2 monitors, though. I tried changing my VM configuration between 1 and 2 screens -- neither configuration worked. Not sure what else to try.

share|improve this question
1  
SOLVED. I uninstalled Guest Additions. Was able to start X after that. This is the command I used: sudo /opt/VBoxGuestAdditions-4.2.0/uninstall.sh –  ComtriS Sep 13 '13 at 3:44
1  
This was exactly the issue I was facing: virtualbox.org/ticket/11709 –  ComtriS Sep 13 '13 at 5:02
1  
If it's solved, please add an answer and accept that. This way, it will be easier to know that it was actually solved. –  Jo-Erlend Schinstad Sep 13 '13 at 7:16
    
I have to wait 8 hours to do that apparently -- very irritating. –  ComtriS Sep 13 '13 at 11:22

1 Answer 1

I uninstalled Guest Additions. Was able to start X after that. This is the command I used:

sudo /opt/VBoxGuestAdditions-4.2.0/uninstall

This was exactly the issue I was facing: https://www.virtualbox.org/ticket/11709

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.